天道酬勤,学无止境

yum

没有名为 rpm 的模块 - 当我在 shell 上调用 yum 时(no module named rpm - when i call yum on shell)

问题 我在centos机器linux os上安装了python 2.7.5和mod_wsgi。 这发生了: # yum Error processing line 1 of /usr/local/lib/python2.7/site-packages/abrt.pth: Traceback (most recent call last): File "/usr/local/lib/python2.7/site.py", line 152, in addpackage exec line File "<string>", line 1, in <module> ImportError: No module named abrt_exception_handler Remainder of file ignored Traceback (most recent call last): File "/usr/bin/yum", line 22, in <module> import yummain File "/usr/share/yum/yummain.py", line 22, in <module> import clientStuff File "/usr/share/yum/clientStuff.py", line 18, in <module> import rpm

2021-07-12 22:28:49    分类:技术分享    python   apache   mod-wsgi   rpm   yum

在 amazon linux 上安装 ffmpeg - cpp、gcc 和 libstdc++ 依赖项(Installing ffmpeg on amazon linux - cpp, gcc & libstdc++ dependancies)

问题 我对复杂的配置还很陌生,我正在尝试使用此处的说明在 amazon linux EC2 实例上设置 ffmpeg... http://wiki.razuna.com/display/ecp/FFMpeg+Installation+on+CentOS+and+RedHat ......但是我在尝试以下行时撞到了墙...... yum install glibc gcc gcc-c++ autoconf automake libtool 这是我遇到的错误... Package matching glibc-2.5-107.x86_64 already installed. Checking for update. Package matching autoconf-2.59-12.noarch already installed. Checking for update. Package matching automake-1.9.6-2.3.el5.noarch already installed. Checking for update. Resolving Dependencies --> Running transaction check ---> Package gcc.x86_64 0:4.1.2-54.el5 will be installed -->

2021-07-11 08:17:13    分类:技术分享    linux   amazon-web-services   yum

cannot install R tseries, quadprog ,xts packages in Linux

I am using R version 3.4.0 I'm trying to install tseries package on linux machine: install.packages('https://cran.cnr.berkeley.edu/src/contrib/tseries_0.10-42.tar.gz',dependencies = TRUE,repos = NULL,type ="source") It gives error: ERROR: compilation failed for package 'xts' * removing '/usr/lib64/R/library/xts' ERROR: dependency 'xts' is not available for package 'TTR' * removing '/usr/lib64/R/library/TTR' ERROR: dependencies 'xts', 'TTR' are not available for package 'quantmod' * removing '/usr/lib64/R/library/quantmod' ERROR: dependencies 'quadprog', 'quantmod' are not available for package

2021-06-27 10:47:33    分类:问答    r   linux   yum   install.packages

no module named rpm - when i call yum on shell

I installed python 2.7.5 and mod_wsgi on centos machine linux os. And this happened: # yum Error processing line 1 of /usr/local/lib/python2.7/site-packages/abrt.pth: Traceback (most recent call last): File "/usr/local/lib/python2.7/site.py", line 152, in addpackage exec line File "<string>", line 1, in <module> ImportError: No module named abrt_exception_handler Remainder of file ignored Traceback (most recent call last): File "/usr/bin/yum", line 22, in <module> import yummain File "/usr/share/yum/yummain.py", line 22, in <module> import clientStuff File "/usr/share/yum/clientStuff.py", line

2021-06-25 20:32:17    分类:问答    python   apache   mod-wsgi   rpm   yum

can't install using yum in RHEL 7.1

I got a RHEL 7.1 instance on amazon aws, now i am trying to install softwares using yum, but even very common softwares aren't available. For example, $ sudo yum install lynx Loaded plugins: amazon-id, rhui-lb No package lynx available. Error: Nothing to do I am new to linux and yum. What's to be done so I can install softwares easily using yum. Should I be adding repos? Here, I tried doing what's said here -> Top 5 Yum Repositories for CentOS/RHEL 7/6/5 and Fedora, and here -> Install RepoForge (RPMForge) Repository On RHEL, CentOS, Scientific Linux 7/6.x/5.x/4.x but to no use. Appreciate any

2021-06-25 07:33:14    分类:问答    linux   redhat   yum   rhel   rhel7

从 Gradle 上传 RPM 到 Artifactory(Upload an RPM to Artifactory from Gradle)

问题 如何使用 Gradle 将 RPM 文件上传到 Artifactory? Gradle 总是使用不适合 YUM 存储库的 Maven 风格直接布局上传文件。 回答1 这里的问题是 Gradle 坚持以group-id/version/artifact的 maven 风格目录格式上传所有内容,而 yum 存储库需要平面布局。 这里有两种方法 - 使用 Artifactory 插件或 Gradles 较新的发布机制。 我只能让它与后者一起工作。 我在这里假设您正在使用 Gradle ospackage 插件并且已经创建了 RPM 构建。 就我而言,RPM 任务的名称是distRpm 。 例如: task distRpm(type: Rpm) { packageName = 'my_package' version = version release = gitHash arch = 'X86_64' os = 'LINUX' // Etc } 将 ivy 发布插件添加到您的项目中: apply plugin: 'ivy-publish' 然后添加一个发布块: publishing { publications { rpm(IvyPublication) { artifact distRpm.outputs.getFiles().getSingleFile() /* Ivy

2021-06-24 16:30:52    分类:技术分享    gradle   rpm   artifactory   yum

如何在亚马逊 linux disto 上安装 nginx 1.9.15(How to install nginx 1.9.15 on amazon linux disto)

问题 我尝试在新的 amazon linux 上安装最新版本的 nginx (>= 1.9.5) 以使用 http2。 我按照此处描述的说明进行操作 -> http://nginx.org/en/linux_packages.html 我使用以下内容创建了一个 repo 文件/etc/yum.repos.d/nginx.repo : [nginx] name=nginx repo baseurl=http://nginx.org/packages/mainline/centos/7/$basearch/ gpgcheck=0 enabled=1 如果我运行yum update和yum install nginx我得到这个: nginx x86_64 1:1.8.1-1.26.amzn1 amzn-main 557 k 似乎它仍然从 amzn-main 回购中获取。 如何安装较新版本的 nginx? -- 编辑 -- 我在 nginx.repo 文件中添加了“priority=10”,现在我可以使用yum install nginx安装 1.9.15,结果如下: Loaded plugins: priorities, update-motd, upgrade-helper Resolving Dependencies --> Running transaction check ---

2021-06-24 06:08:47    分类:技术分享    amazon-web-services   nginx   amazon-ec2   yum   amazon-ami

sudo yum install postfix mysql-libs error

I am trying to install postfix through yum: sudo yum install postfix After I run the code below I get the following error: Loading mirror speeds from cached hostfile * rpmforge: mirror.hmc.edu Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package postfix.x86_64 2:2.6.6-6.el6_5 will be installed --> Processing Dependency: mysql-libs for package: 2:postfix-2.6.6-6.el6_5.x86_64 --> Finished Dependency Resolution Error: Package: 2:postfix-2.6.6-6.el6_5.x86_64 (updates) Requires: mysql-libs You could try using --skip-broken to work around the problem ** Found

2021-06-23 14:48:08    分类:问答    mysql   postfix-mta   yum

Installing php-soap with yum and pear both fail

I am trying to install the SOAP extension for PHP on a Centos 6.4 server. I am fairly unfamiliar with package managers, installing packages from the CLI and configuring them within PHP. I am fairly competent with managing the php.ini and other PHP config files (soap.ini etc). I have tried installing this using the command: yum install php-soap but this gives me the following error: yum install php-soap Loaded plugins: downloadonly, fastestmirror Setting up Install Process Loading mirror speeds from cached hostfile drivesrvr | 951 B 00:00 Resolving Dependencies There are unfinished transactions

2021-06-23 13:48:37    分类:问答    php   soap   pear   centos6   yum

I can't install any package related to PHP with yum

I can't install any package related PHP, I get a yum error: No package php available. My PHP version is 5.4.37 on Centos 7. I installed remi for other purposes and I think that the repository is not compatible with PHP version but I don't know how to fix it. [root@server ~]# sudo yum install php php-pear Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: centosmirror.netcup.net * epel: mirrors.n-ix.net * extras: centosmirror.netcup.net * remi: mirror5.layerjet.com * remi-safe: mirror5.layerjet.com * updates: centosmirror.netcup.net No package php available. No

2021-06-23 11:27:18    分类:问答    php   yum   centos7