天道酬勤,学无止境

ubuntu-9.10

Mysql ERROR 1005 (HY000): Can't create table 'tmp' (errno: 13)

I'm Running Mysql on ubuntu 9.10, the process of Mysql is running as root, I'm using root account when logging to Mysql, which I gave all privileges, I'm using my own db(not mysql), I can create a table, but when i try to create Temporary table i get this error: ERROR 1005 (HY000): Can't create table 'tmp' (errno: 13) For this query: CREATE TEMPORARY TABLE tmp (id int); I've plenty of space in my hard drive, all permissions are granted(also var/lib/mysql have mysql permissions). Any idea? Thanks, Koby

2022-03-26 13:35:08    分类:问答    mysql   ubuntu   ubuntu-9.10   mysql-error-1005

changed sudo path, command continues not being found

I added export PATH="/home/deltrem/Pedro - Arquivos/play/ps1/linux/pSX:$PATH" to /root/.bashrc , but sudo pSX echoes command not found.

2022-03-22 04:08:27    分类:问答    linux   ubuntu-9.10   sudo

制作一个 Ubuntu 可执行文件(Making a Ubuntu executable)

问题 我使用 gcc 编译器用 C 语言编写了一个程序。 现在它没有 GUI 组件。 我正在用 makefile 编译它并在终端中运行它。 我需要部署它,以便可执行文件是独立的。 我希望可执行文件有一个图标,并在单击时在终端中启动程序。 谁能告诉我该怎么做? 回答1 基础 (免责声明:以下是用 kubuntu 测试的,您可能需要对您的系统进行一些调整) 实际上有一个标准可以做到这一点,不仅适用于 Ubuntu,而且适用于任何数量的 *nix 系统。 咨询:http://www.freedesktop.org/wiki/Howto_desktop_files: 假设您有要部署的foo.bin文件。 根据文件系统层次标准,放置它的好地方(如果您不使用包管理器)是/usr/local/bin/ 。 你还需要一个图标,我会假设你的艺术天赋产生了foo.png ,它的好地方可能是/usr/local/share/icons/ 。 现在您需要创建foo.desktop : [Desktop Entry] Comment=My awesome fooish application Exec=/usr/local/bin/foo.bin Icon=/usr/local/share/icons/foo.png Name=Foobar NoDisplay=false StartupNotify

2022-01-12 19:55:44    分类:技术分享    c   linux   gcc   executable   ubuntu-9.10

Making a Ubuntu executable

i have made a program in C using the gcc compiler. Right now it has no GUI components. I am compiling it with makefile and running it in the terminal. I need to deploy it so that the executable is standalone. I want the executable to have an icon and when clicked start the program in the terminal. Can anyone tell me how to do this?

2022-01-08 07:56:40    分类:问答    c   linux   gcc   executable   ubuntu-9.10

如何配置多个 Ubuntu Python 安装以避免 App Engine 的 SSL 错误?(How do I configure multiple Ubuntu Python installations to avoid App Engine's SSL error?)

问题 我有 Karmic Koala,它默认安装了 Python 2.6。 但是我无法运行任何 Python App Engine 项目,因为它们需要 Python 2.5 和 python ssl。 为了安装 ssl,我首先安装了 python2.5-dev,同时遵循了我在别处找到的一些说明。 sudo apt-get install libssl-dev sudo apt-get install python-setuptools sudo apt-get install python2.5-dev sudo easy_install-2.5 pyopenssl 但是,我担心这对我的 Ubuntu 安装不利,因为当您在命令行中键入“python”时,Ubuntu 希望看到 Python 2.6 版。 相反,它说“2.5.5”。 但是在这一切之后,App Engine 仍然无法正常工作。 每当我尝试运行我的 Python 应用程序时,我都会继续收到与 SSL 相关的错误: AttributeError: 'module' object has no attribute 'HTTPSHandler' UPDATE1:通过键入以下命令检查是否确实安装了 SSL 作为这些命令的结果: $ python2.5 Python 2.5.5 (r255:77872, Apr 29 2010

2021-11-29 00:38:02    分类:技术分享    python   google-app-engine   ssl   ubuntu-9.10

How do I configure multiple Ubuntu Python installations to avoid App Engine's SSL error?

I have Karmic Koala which has Python 2.6 installed by default. However I can't run any Python App Engine projects because they require Python 2.5 and python ssl. To install ssl I installed python2.5-dev first while following some instructions I found elsewhere. sudo apt-get install libssl-dev sudo apt-get install python-setuptools sudo apt-get install python2.5-dev sudo easy_install-2.5 pyopenssl However, I am afraid this is not good for my Ubuntu installation since Ubuntu expects to see version 2.6 of Python when you type 'python' on the command line. Instead, it says '2.5.5'. But App Engine

2021-11-22 01:56:13    分类:问答    python   google-app-engine   ssl   ubuntu-9.10

使用 XAMPP 在 Ubuntu 上安装 Xdebug for PHP(Installing Xdebug for PHP on Ubuntu with XAMPP)

问题 我在 Ubuntu 9.10 上运行 XAMPP 1.7.3a。 使用 Netbeans 6.7.1 作为我的编辑器,我希望能够调试我的 PHP 站点。 为此,我查找了 Xdebug 并开始按照安装说明进行操作,在此处找到:http://xdebug.org/docs/install。 尝试编译 .tgz 文件时遇到问题。 第 3 步)我可以执行那个,但它有什么用? 我没有得到输出或我应该用它做什么。 步骤 4)我执行以下命令: ./configure --enable-xdebug --with-php-config=/opt/lampp/etc/ 在输出的底部,它说:配置: 错误:找不到 php-config。 请使用 --with-php-config=PATH 我检查了我输入的位置,php.ini 文件在那里,所有其他配置文件也在那里。 所以,我不知道现在该怎么办。 我应该忽略并只执行“make”命令,还是还需要做其他事情? 回答1 你必须将路径传递给 php 配置二进制文件 - 应该是这样的 /opt/lampp/bin/php-config 回答2 XAMPP中的所有二进制文件都位于 /opt/lampp/bin 这就是为什么如果您使用 XAMPP 的 PHP 版本,您应该使用那里的二进制文件进行所有操作。 例如,安装 XAMPP 后,可以设置它的 PHP bin

2021-11-11 21:57:56    分类:技术分享    php   xampp   xdebug   ubuntu-9.10

Installing Xdebug for PHP on Ubuntu with XAMPP

I'm running XAMPP 1.7.3a on Ubuntu 9.10. With Netbeans 6.7.1 as my editor, I want to be able to debug my PHP sites. To do this, I looked up Xdebug and started following the installation instructions, found here: http://xdebug.org/docs/install. Trying to compile the .tgz file, run in to a problem. Step 3) I can execute that, but what use does it have? I don't get the output or what I should do with it. Step 4) I execute the following command: ./configure --enable-xdebug --with-php-config=/opt/lampp/etc/ At the bottom of the output, it says: configure: error: Cannot find php-config. Please use -

2021-11-10 05:17:02    分类:问答    php   xampp   xdebug   ubuntu-9.10