天道酬勤,学无止境

galileo

如何以正确的方式将 Eclipse 从 3.5 (Galileo) 升级到 3.6 (Helios)?(How to upgrade Eclipse from 3.5 (Galileo) to 3.6 (Helios) the proper way?)

问题 我注意到这个问题已被问过几次,但我真的不喜欢并行使用两个 Eclipse 的解决方案。 我只希望我的 Galileo 升级到 Helios,并保留所有设置、插件和工作区,而不像手动复制插件之类的笨拙。 我有 Android 插件、C/C++ 插件、PyDev 插件等等。 有没有一种快速而可靠的方法来像这样升级 Eclipse? 我在 Eclipse wiki 上找到了一些说明,但它似乎不适用于我的系统(Ubuntu 10.04;我添加了 Helios 站点,然后检查更新,但它没有将 Helios 作为 Eclipse 的更新) . 有人为此找到了解决方案吗? 更新:wiki 中描述的方式似乎适用于我的 Windows 安装的 Eclipse,检查更新将“Eclipse SDK v.3.6.0”列为可用更新。 回答1 你不能。 您必须在没有 ubuntu 存储库的情况下下载、解压缩并运行它。 在这种情况下,您可以毫无问题地升级;-) 如果您想通过 ubuntu 存储库使用 Helios,您必须等待 Maverick (10.10) 之后,如您所见:https://launchpad.net/ubuntu/+source/eclipse 回答2 希望这会为某些人省去一些麻烦...我从 zip 安装了 Helios,但发现 Eclipse 由于依赖关系而无法安装新插件。

2021-12-21 14:56:30    分类:技术分享    eclipse   ubuntu   upgrade   galileo   helios

How to upgrade Eclipse from 3.5 (Galileo) to 3.6 (Helios) the proper way?

I notice this question has been asked a few times but I don't really like the solution with two Eclipses in parallel. I just want my Galileo upgraded to Helios with preservation of all settings, plugins and workspaces, without the mumbo-jumbo like copying plugins manually and stuff. I've got the Android plugin, the C/C++ plugin, the PyDev plugin and what not more. Is there a quick and sure way to upgrade Eclipse like this? I've found some instructions on the Eclipse wiki, but it doesn't seem to work with my system (Ubuntu 10.04; I add the Helios site and then Check for Updates, but it doesn't

2021-12-12 05:11:44    分类:问答    eclipse   ubuntu   upgrade   galileo   helios

Eclipse Galileo supports javascript cross-file code completion, but Eclipse Helios does not?

When editing multiple javascript files, each of which are supposed to be available in the global scope because - for example - they will each be loaded in the same html document, Galileo supported this little trick to put comment tags for other files that are required to be available in the same scope: myfile.js: // @include "somefile.js" // @include "otherfile.js" And you have cross-file code completion in myfile.js. But now that I moved to Eclipse Helios, this doesn't work anymore. Did they move similar functionality to some other method?

2021-06-09 21:39:56    分类:问答    javascript   eclipse   code-completion   helios   galileo

Ubuntu 9.10上的Eclipse Galileo单击问题(Eclipse Galileo click problem on Ubuntu 9.10)

问题 我刚刚将Ubuntu从9.04升级到9.10,并且正在尝试使用Eclipse Galileo解决一个非常烦人的问题。 问题在于Eclipse不能捕获某些按钮单击。 例如,我尝试安装插件,然后单击“下一步”,然后什么也没有发生。 升级Ubuntu版本之前,我没有遇到同样的问题。 回答1 这是Eclipse 3.5和GTK + 2.8(在Eclipse 3.6中修复)中的一个已知错误(错误291257)。 解决方法是在启动Eclipse之前将GDK_NATIVE_WINDOWS环境变量设置为true 。 我将以下启动脚本用于Eclipse: #!/bin/sh export MOZILLA_FIVE_HOME=/usr/lib/mozilla/ export ECLIPSE_HOME=/opt/IBM/eclipse export GDK_NATIVE_WINDOWS=true # workaround for Karmic - http://bit.ly/T8MIc $ECLIPSE_HOME/eclipse $* 重要的部分是行export GDK_NATIVE_WINDOWS=true 。 回答2 Karmic改变了GTK。 以下是相关的错误: https://bugs.launchpad.net/ubuntu/+source/swt-gtk/+bug/463086

2021-05-20 10:10:49    分类:技术分享    eclipse   click   ubuntu-9.10   galileo

在Mac上使用Eclipse Galileo调试C ++时遇到问题(Trouble debugging C++ using Eclipse Galileo on Mac)

问题 我试图在运行Mac OS X v10.5(Leopard)的MacBook Pro上使用Eclipse Galileo调试C ++代码。 这是我第一次尝试。 我有一个想要调试的复杂C ++程序,但是为了进行测试,我只是尝试调试并逐步进行以下操作: #include <iostream> using namespace std; int main() { int x = 0; cout << x << endl; x = 54; cout << x << endl; return 0; } 我单击了调试图标,告诉它使用GDB(DSF)Create Process Launcher,然后开始逐步执​​行代码。 我希望能够监视x的值,所以我打开了Variables窗口并进行了观察。 最初是4096,大概是垃圾值。 当我点击显示值的下一行时,它现在显示以下错误: Failed to execute MI command: -var-update 1 var1 Error message from debugger back end: Variable object not found 我似乎无法弄清楚或解决它。 而且,一些Google搜索甚至没有线索就干了。 解决方案:正如drhirsch在下面指出的那样,请使用“标准创建流程启动器”而不是“ GDB创建流程启动器”。

2021-05-17 16:33:25    分类:技术分享    c++   eclipse   macos   gdb   galileo

如何编写Delphi Galileo IDE Expert?(How do I write a Delphi Galileo IDE Expert?)

问题 你好, 我想编写一个用于D2007-D2009(又称Galileo IDE)的小型Delphi IDE专家,以便显示一个带有TMemo实例的窗口,其中包含以上备注中来自表单设计器的所有组件名称和类。 所选组件将标有“ *”。 专家应出现在菜单/工具栏上,并分配有快捷方式。 我该怎么办? 附言:实际上,实际的代码要比这复杂得多,但是我希望有一个通用的框架来入门。 TIA 回答1 我通过以下链接进行了首次OTA: Erik的Open Tools API常见问题和资源(GExpert的作者) Jim Kueneman的Delphi Open Tools API-Mustangpeak RayRay Lischner的Delphi Open Tools API 它们没有更新为最新版本,但是它们将为您提供一个良好的起点,并且大多数代码都可以在最新版本中使用,我在D2007中对其进行了尝试。 回答2 这里有指向描述如何编写OTA插件的文章的链接:http://delphi.about.com/od/objectpascalide/a/wizardsexperts.htm

2021-05-12 15:46:00    分类:技术分享    delphi   ide   galileo   ota

Trouble debugging C++ using Eclipse Galileo on Mac

I am trying to debug C++ code using Eclipse Galileo on my MacBook Pro running Mac OS X v10.5 (Leopard). It's my first time trying this. I have a complicated C++ program I'd like to debug, but to test things out, I just tried to debug and step through the following: #include <iostream> using namespace std; int main() { int x = 0; cout << x << endl; x = 54; cout << x << endl; return 0; } I clicked the debug icon, told it to use GDB (DSF) Create Process Launcher and started to step through the code. I wanted to be able to monitor the value of x, so I opened up the Variables window and watched

2021-05-03 00:59:58    分类:问答    c++   eclipse   macos   gdb   galileo

How do I write a Delphi Galileo IDE Expert?

HI, I want to write a small Delphi IDE Expert for D2007-D2009 (aka. Galileo IDE) in order to show a window with a TMemo instance on it, with all the component names and classes from the form designer in the above memo. The selected component will be marked with a '*'. The expert should appear on a menu/toolbar and have a shortcut assigned. How do I do? Ps: Actually the real code is more complicated than that, but I want to have a general framework to get started. TIA

2021-04-30 15:00:44    分类:问答    delphi   ide   galileo   ota

Eclipse-Mac Os默认JRE丢失(Eclipse - Mac Os Default JRE missing)

问题 安装的JRE列表为空,当我单击“添加”时,我得到的唯一选项是-执行环境描述,Standard 1.1.x VM,Standard VM。 MacOS默认JRE没有选项,选择标准VM会导致通常的“ MacOS不支持标准VM”。 Eclipse Galileo,Mac OS X 10.5.8。 任何建议,不胜感激 回答1 我只是遇到了同样的问题,并且能够解决它。 我安装了Eclipse for PHP(PDT),因为无法让PDT与Eclipse classic一起使用。 然后,我发现在进行新安装后,Java文件将无法运行! 但是有一个简单的解决方案: 转到“帮助”->“安装新软件...”。 选择: 伽利略-http://download.eclipse.org/releases/galileo 在“编程语言”下,选择: Eclipse Java开发工具3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ 安装后,您将找到自己的JRE! 回答2 1)按照Joshua的回答:“帮助->安装新软件...选择:Galileo-http://download.eclipse.org/releases/galileo在“编程语言”下选择:Eclipse Java开发工具3.5.x ...” 2)然后转到Eclipse->首选项->

2021-04-27 12:28:15    分类:技术分享    eclipse   macos   java   galileo

Eclipse Galileo click problem on Ubuntu 9.10

I've just upgrade my Ubuntu from 9.04 to 9.10 and I'm experimenting a very annoying problem with Eclipse Galileo. The problem is that Eclipse doesn't catch some button clicks. For example, I've tried to install a plugin and I clicked on next, and then nothing happened. I didn't have the same problem before the upgrade of my Ubuntu version.

2021-04-26 09:02:27    分类:问答    eclipse   click   ubuntu-9.10   galileo