天道酬勤,学无止境

flutter-android

颤振中的 SignalR 出现错误 无协议(SignalR in flutter getting error No Protocol)

问题 我在flutter应用程序中使用pub包signalr_flutter,并且我有SignalR(构建在.Net框架上),它在浏览器中运行良好。 但是当我尝试从颤振连接 SignalR 时出现错误 no protocol: dev.mysignalr.com/signalr/negotiate?clientProtocol=1.3&connectionData=%5B%7B%22name%22%3A%22chathub%22%7D%5D 飞镖代码片段 // Platform messages are asynchronous, so we initialize in an async method. Future<void> initPlatformState() async { signalR = SignalR('dev.mysignalr.com', "ChatHub", hubMethods: ["Send"], //headers: hed, statusChangeCallback: _onStatusChange, hubCallback: _onNewMessage); }

2021-10-31 00:14:33    分类:技术分享    flutter   dart   signalr   flutter-android

如何在 Flutter 中构建 apk 创建旧版本的应用程序(how to build apk create old version app in Flutter)

问题 我是一个新的 flutter 程序员,我正在尝试在 flutter 和运行时构建我的发布应用程序 flutter run 在调试和测试模式下一切正常。 但是当我试图构建一个发布应用程序时 flutter build apk 它创建了我的一个旧的首次发布应用程序。 我之前创建的,我尝试重置计算机重置 android 和一切但不起作用我该怎么做才能重置它并清除缓存? 我几乎试图删除和重置所有内容,但它们不起作用。 我必须运行什么命令来修复它并创建新版本发布 apk 回答1 解决办法很简单。 只需运行flutter clean并在此之后运行flutter build apk并生成更新应用程序 apk。 如果你想直接安装它,只需在构建命令后运行flutter install 。 回答2 可以通过 Android Studio 轻松完成 回答3 如果flutter clean和flutter build apk也在您的 pubspec.yaml 中生成带有旧版本代码的 apk,请更改版本如下: 1.0.2+2前 + 是您的版本名称,后 + 是您的版本代码 注意:您的新版本号应该在 2 的位置。或者您可以使用不同的格式,例如1.2+2 回答4 致所有初学者如果你想发布一个 flutter 应用程序的 apk 只需执行以下操作: flutter run --release

2021-10-22 12:04:18    分类:技术分享    flutter   dart   build   apk   flutter-android

无法为flutter构建发布APK(Can't build release APK for flutter)

问题 我目前正在尝试使用 Flutter 在 Windows 上构建签名版本 APK。 我已经执行了 flutter 站点上的文档中概述的任务。 当我运行构建命令时,这是我得到的输出。 它似乎围绕着firebase插件。 有任何想法吗? pubspec.yaml dependencies: flutter: sdk: flutter firebase_auth: 0.4.0 firebase_database: ^0.3.0 颤振医生输出 C:\Users\myuser\projects\myflutterapp>flutter doctor [√] Flutter (on Microsoft Windows [Version 10.0.16299.125], locale en-US, channel alpha) • Flutter at C:\Users\myuser\flutter • Framework revision 8f65fec5f5 (3 weeks ago), 2017-12-12 09:50:14 -0800 • Engine revision edaecdc8b8 • Tools Dart version 1.25.0-dev.11.0 • Engine Dart version 2.0.0-edge

2021-10-21 00:15:38    分类:技术分享    firebase   flutter   release   flutter-release   flutter-android

SignalR in flutter getting error No Protocol

I am using pub package signalr_flutter in flutter app and I have SignalR(build on .Net framework) which is working fine in browser. But when I am trying to connect SignalR from flutter then getting error no protocol: dev.mysignalr.com/signalr/negotiate?clientProtocol=1.3&connectionData=%5B%7B%22name%22%3A%22chathub%22%7D%5D dart code snippet // Platform messages are asynchronous, so we initialize in an async method. Future<void> initPlatformState() async { signalR = SignalR('dev.mysignalr.com', "ChatHub", hubMethods: ["Send"], //headers: hed, statusChangeCallback: _onStatusChange, hubCallback

2021-10-20 02:42:05    分类:问答    flutter   dart   signalr   flutter-android

Unable to compile Flutter application with Flutter 1.22.3

My application was compiling successfully until the Flutter version upgrade. I get the following error: Runner.app/Info.plist does not exist. The Flutter "Thin Binary" build phase must run after "Copy Bundle Resources". Flutter doctor -v [✓] Flutter (Channel stable, 1.22.3, on Mac OS X 10.15.6 19G2021, locale fr-FR) • Flutter version 1.22.3 at /Users/xxx/development/flutter • Framework revision 8874f21e79 (3 days ago), 2020-10-29 14:14:35 -0700 • Engine revision a1440ca392 • Dart version 2.10.3 [✓] Android toolchain - develop for Android devices (Android SDK version 29.0.2) • Android SDK at

2021-06-05 05:04:46    分类:问答    ios   flutter   flutter-android

how to build apk create old version app in Flutter

I am a new flutter programmer and I am trying to build my release app in flutter and when I run flutter run everything works fine in debugging and test mode. but when I was trying to build a release app with flutter build apk it creates an old first-release app of mine. that I created before and I try to reset the computer reset android and everything but not work what can I do to reset it and clear the cache? I'm trying almost to delete and reset everything but they don't work. what command that I have to run to fix it and create new version release apk

2021-05-16 03:06:43    分类:问答    flutter   dart   build   apk   flutter-android

Flutter.io Android许可证状态未知(Flutter.io Android License Status Unknown)

问题 [!] Android工具链-为Android设备开发(Android SDK 27.0.3)>>•Android SDK a .. \ Android \ sdk•未配置Android NDK位置(可选;对本机性能分析支持很有用)•平台android-27,构建工具27.0.3•Java二进制文件位于C:\ Program Files \ Android \ Android Studio \ jre \ bin \ java•Java版本OpenJDK运行时环境(内部版本1.8.0_152-release-1024-b02)X And​​roid许可证状态未知。 运行Flutter doctor时,Android SDK出现错误,尽管我仍然可以在设备上构建/运行它。 我只是对如何解决此问题感到好奇。 我相信我已经下载了最新版本的Android SDK,不确定发生了什么事,因为上周我没有遇到这个问题。 ##新问题在注释中进行了几种可能的修复后,它导致了一个新问题。 我安装了较新版本的android sdk P,8和7,以及新的jdk10。 显然还没有足够的更新。 C:\Flutter\flutter>flutter doctor --android-licenses A newer version of the Android SDK is required. To

2021-04-19 07:27:51    分类:技术分享    java   android   flutter   flutter-android   android-licenses

Can't build release APK for flutter

I'm currently trying to build a signed release APK on Windows using Flutter. I've performed the tasks outlined in the documentation on the flutter site. When I run the build command here's the output I get. It seems to be around the firebase plugins. Any ideas? pubspec.yaml dependencies: flutter: sdk: flutter firebase_auth: 0.4.0 firebase_database: ^0.3.0 Flutter Doctor Output C:\Users\myuser\projects\myflutterapp>flutter doctor [√] Flutter (on Microsoft Windows [Version 10.0.16299.125], locale en-US, channel alpha) • Flutter at C:\Users\myuser\flutter • Framework revision 8f65fec5f5 (3 weeks

2021-04-15 05:05:55    分类:问答    firebase   flutter   release   flutter-release   flutter-android

Flutter stuck at Installing build\app\outputs\apk\app.apk

when I run $ flutter run I'm getting a prompt on my mobile device asking if I want to install the app on my device. I give yes, then nothing happening! It's stuck here Launching lib/main.dart on POCO F1 in debug mode... Initializing gradle... 1.5s Resolving dependencies... 9.2s Gradle task 'assembleDebug'... 22.9s Built build\app\outputs\apk\debug\app-debug.apk. Installing build\app\outputs\apk\app.apk... 14.9s Then nothing.

2021-04-08 14:37:46    分类:问答    flutter   dart   apk   flutter-release   flutter-android

Flutter.io Android License Status Unknown

[!] Android toolchain - develop for Android devices (Android SDK 27.0.3) >>• Android SDK a ..\Android\sdk • Android NDK location not configured (optional; useful for native profiling support) • Platform android-27, build-tools 27.0.3 • Java binary at C:\Program Files\Android\Android Studio\jre\bin\java • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1024-b02) X Android license status unknown. I am getting an error with Android SDK when I run Flutter doctor, although I can still build/run it on my device. I was just curious about how to fix this issue. I believe I have the

2021-03-26 23:03:33    分类:问答    java   android   flutter   flutter-android   android-licenses