天道酬勤,学无止境

apple-m1

Apple Silicon Android Studio emulator: ERROR: can't find the emulator executable

I just installed Android Studio 4.2.2 and Android Studio Preview (Arctic Fox Beta 5) to my Apple M1 Macbook. When creating an emulator (arm64) I immediately receive the error: AVD Manager: The emulator process for AVD Pixel_4a_API_30 has terminated I then went to the log file of Android Studio (Help > Show log in Finder) and I see that the error occurs when Android Studio attempts to run the following: ~/Library/Android/sdk/emulator/emulator -netdelay none -netspeed full -no-snapshot-load -avd Pixel_4a_API_30 which outputs: emulator: Android emulator version 30.3.5.0 (build_id 7036990) (CL:N/A

2022-06-06 01:50:06    分类:问答    android   android-studio   apple-m1   android-sdk-manager   apple-silicon

Android studio Arctic Fox beta 3 on M1 Chip (Apple silicon) emulator cannot start: "The emulator process for AVD 'myAvdName' has terminated."

Have Android studio both official latest and Arctic Fox Beta 3 installed on my MacBook Air M1. cannot get the emulator running on neither edition of android stood. "The emulator process for AVD 'myavxname' has terminated." I have made sure I use the other (ARM image) instead of the Intel ones, as there are quite some posts on the web and it seems those post saved many, not me. I use the command in terminal to check more helpful error message: ~/Library/Android/sdk/emulator/emulator -avd P4S , p4s is my emulator config name. also run the command pip3 install opencv-python-headless still blocked

2022-05-03 08:42:52    分类:问答    android   qt   emulation   apple-m1

How to install MAMP PHP zip extension on masOS Big Sur - M1 arch?

I'm trying to install php zip module on my new Macbook M1, by using: pecl install zip After a while i'm getting this error: configure: error: Please reinstall the libzip distribution ERROR: `/private/tmp/pear/temp/zip/configure --with-php-config=/Applications/MAMP/bin/php/php7.4.15/bin/php-config' failed So i run: brew install libzip And i get: Warning: libzip 1.7.3 is already installed and up-to-date. At this point i'm stucked. Any idea? Thank you

2022-05-03 05:59:26    分类:问答    php   homebrew   pecl   apple-m1   libzip

OSError: libgdal.dylib: cannot open file

The problem is: Docker doesn't run properly because of OSError: /opt/homebrew/Cellar/gdal/3.3.0_2/lib/libgdal.dylib: cannot open shared object file: No such file or directory. My current task is just to add GeoDjango to my existing Django dockerized project, with PostGIS database. I installed postgis image with postgis/postgis. I Butguess something went wrong because of the incorrect gdal installation. I installed gdal with Homebrew. To be honest, I do not understand why do I need gdal on my machine if I use Docker. Now I use Big Sur OS on the MacBook Air (M1, 2020) and the last versions of

2022-05-03 01:14:12    分类:问答    docker   postgis   gdal   apple-m1

InvocationTargetException with Android Arctic Fox | 2020.3.1 arm64 on M1 Apple silicon

During a build of my Android project on my M1 Apple Silicon using kapt (eg Room) Android Studio Arctic Fox | 2020.3.1 Beta 1 arm64 .. Android Studio Arctic Fox | 2020.3.1 Beta 5 arm64 Android Studio Bumblebee | 2021.1.1 Canary 2 aarch64 With Android Studio Arctic Fox | 2020.3.1 Beta 5 Build #AI-203.7717.56.2031.7360992, built on May 14, 2021 Runtime version: 11.0.10+0-b96-7249189 aarch64 VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o. macOS 11.4 I run into Execution failed for task ':FFTSpectrumLib:kaptDebugKotlin'. > A failure occurred while executing org.jetbrains.kotlin.gradle.internal

2022-05-03 00:58:24    分类:问答    android   arm64   apple-m1   apple-silicon   kapt

Docker/Cypress Container Failing Due to Qemu Error on M1 Chip

I have a Docker image that I'd like to run locally but I believe it's failing due to an issue with Qemu, which seems to stem from attempting to run Cypress on an M1 chip: REPOSITORY TAG IMAGE ID CREATED SIZE dna local 097c5f291db5 2 hours ago 3.66GB When I attempt to run the image locally using docker run dna:local I get the following: WARNING: The requested image's platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested yarn run v1.22.10 $ concurrently "yarn:start:ui" "yarn:start:api" "cypress run" [start:api] $ cd api && yarn

2022-05-02 22:54:04    分类:问答    docker   cypress   apple-m1

How to fix this import pandas problem in M1 Mac?

I bought Mac M1, and now setting up my python environment. I installed Rosetta 2, and set my Terminal as Rosetta 2 I installed pyenv with brew installed Sqlite3 with brew installed python 3.9.4 with pyenv (set as global) installed visual studio code with brew and finally I installed pandas with "pip install pandas" in my Terminal. Now I opened a jypyter notebook file in VS Code, and trying to import pandas as pd, then it threw in this error: --------------------------------------------------------------------------- ImportError Traceback (most recent call last) /var/folders/r5

2022-05-02 22:43:18    分类:问答    python   pandas   visual-studio-code   apple-m1   pyenv

Why am I getting the error ''FirebaseCore/FirebaseCore.h' file not found' when trying to run my iOS app

I recently started using a MacBook pro with the M1 chip from an older MacBook Pro which had no issues running this app. Now when I try to build and run my app I get the following issues: 'FirebaseCore/FirebaseCore.h' file not found and Could not build Objective-C module 'Firebase' What I have tried: cleaning my build folder deleting derived data restarting my computer running pod install --repo-update The error does go away when I change my Scheme to FirebaseCore, but then I am unable to run the app on a simulator. Here is my pod file: # Uncomment the next line to define a global platform for

2022-05-02 10:42:31    分类:问答    ios   swift   firebase   cocoa   apple-m1

Mac M1 - Cocoapods not working (Flutter) verify_minimum_git_version

I am trying to get the Cocoapods running on my Mac Book Pro M1 and am currently trying the following solution: Source: https://stackoverflow.com/a/65334677/16114837 But at the second step I get this error: arch -x86_64 pod install Traceback (most recent call last): 5: from /usr/local/bin/pod:23:in `<main>' 4: from /usr/local/bin/pod:23:in `load' 3: from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/bin/pod:55:in `<top (required)>' 2: from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/command.rb:49:in `run' 1: from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods

2022-05-02 10:36:07    分类:问答    ruby   flutter   github   cocoapods   apple-m1

Unable to install firebase-admin pip package for python django in Apple M1 chip

Unable to install firebase-admin in Apple M1 Chip System System Configuration System OS: macOS Bigsur(11.2.2) chip: Apple M1 python version: 3.9.2 Pip Version: 20.0.1 Djnago: 3.1.7 I create virtual env for my project using below steps install virtualenv using pip install virtualenv virtualenv venv -p python3.x (whichever you want) source /your_project/venv/bin/activate your venv will activate and then you can install requirements with the help of pip After this i try to install firebase-admin pip install firebase-admin and i get error like below File "/private/var/folders/2l

2022-05-02 09:14:07    分类:问答    python   django   pip   firebase-admin   apple-m1