天道酬勤,学无止境

捆绑安装和红宝石版本?(bundle install and ruby versions?)

问题
Installing paperclip (3.1.2) Gem::InstallError: paperclip requires Ruby version >= 1.9.2. An error occured while installing paperclip (3.1.2), and Bundler cannot continue. Make sure that `gem install paperclip -v '3.1.2'` succeeds before bundling.
回答1
回答2
回答3

受限制的 HTML

  • 允许的HTML标签:<a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type> <li> <dl> <dt> <dd> <h2 id> <h3 id> <h4 id> <h5 id> <h6 id>
  • 自动断行和分段。
  • 网页和电子邮件地址自动转换为链接。

相关推荐
  • 捆绑安装是否使用其他Ruby版本?(Bundle install is using a different Ruby version?)
    问题 我尝试使用小刀独奏在Vagrant上安装Ruby 2.0.0-p353。 当我以root身份和无业游民身份登录时, ruby -v返回Ruby 2.0.0-p353。 但是,当我在Rails项目中运行bundle install时,将显示以下语句: Your Ruby version is 1.8.7, but your Gemfile specified 2.0.0 Ruby的默认版本是1.8.7,因此我认为bundle install是指此版本。 我该怎么做才能解决这个问题? $ cat site-cookbooks/ruby/recipes/default.rb group 'rbenv' do action :create members 'vagrant' append true end git '/usr/local/rbenv' do repository 'git://github.com/sstephenson/rbenv.git' reference 'master' action :checkout user "#{node.user}" group 'rbenv' end directory '/usr/local/rbenv/plugins' do owner "#{node.user}" group 'rbenv' mode 0755 action
  • Bundle 说 gem 丢失了 - 但事实并非如此?(Bundle says gem is missing - but it's not?)
    问题 背景 我正在维护 Ruby On Rails 站点的内容,但我真的没有使用 Rails 的经验。 当尝试运行 Rails 服务器时: rails s我得到这个: 在任何来源中都找不到 activesupport-3.2.0 运行bundle install来安装缺少的 gems 我运行捆绑安装 Gem::InstallError: factory_girl 需要 Ruby 版本 >= 1.9.2。 安装 factory_girl (3.2.0) 时出现错误,Bundler 无法继续。 在捆绑之前确保gem install factory_girl -v '3.2.0'成功。 好的,我按照说明安装 factory_girl: 安装成功 factory_girl-3.2.0 1 gem 安装 再次运行捆绑安装: Gem::InstallError: factory_girl 需要 Ruby 版本 >= 1.9.2。 安装 factory_girl (3.2.0) 时出现错误,Bundler 无法继续。 在捆绑之前确保gem install factory_girl -v '3.2.0'成功。 你有什么主意吗? 信息 昨天我在尝试运行 rails 服务器时遇到了交叉错误。 因此,根据这个 SO 建议,我建议我使用 nuked RVM 并安装 rbenv 和 bundler 而不是
  • 供应商/捆绑包和红宝石版本(vendor/bundle and ruby version)
    问题 我想知道我是否在使用 rbenv 和 bundler 时做得不正确。 我正在使用rbenv和 ruby​​ 2.1.2,就像这样 rbenv versions system * 2.1.2 (set by /home/deploy/cp/repo/.ruby-version) 我跑 bundle install --deployment --without=development,test --path=vendor/bundle 从/home/deploy/cp 但得到 vendor/bundle/ruby/2.1.0 用我所有的宝石创造。 是否有我不知道捆绑程序的版本控制方案,或者我应该看到一个 /home/deploy/cp/repo/vendor/bundle/ruby/2.1.2 给你? 回答1 我也注意到了这一点,我只是假设它一定只是 Bundler 正在使用的约定。 我有已从 1.9.3 升级到 2.1.2 的应用程序,并且我有: /path/to/shared/bundle /ruby /1.9.1 /2.1.0 这些机器从未安装过 1.9.1 或 2.1.0,只有 1.9.3 和 2.1.2。 编辑:好的,所以我很开心......它来自 Bundler::Installer#generate_standalone 中的RbConfig : (nick
  • 无法加载此类文件-捆绑程序/安装程序(LoadError)(cannot load such file — bundler/setup (LoadError))
    问题 我正在用Ruby 2.0设置Rails 4应用程序,但是我得到“无法启动Web应用程序”并得到以下跟踪信息: cannot load such file -- bundler/setup (LoadError) /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require' /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require' /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/lib/phusion_passenger/loader_shared_helpers.rb:212:in `run_load_path_setup_code' /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/helper-scripts/rack-preloader.rb:96:in `preload_app' /usr/lib/ruby/gems/1.8/gems/passenger-4.0.19/helper-scripts/rack-preloader.rb:150:in `
  • 新的Rails项目:“捆绑安装”无法在gemfile中安装rails(New Rails Project: 'bundle install' can't install rails in gemfile)
    问题 我已经安装了一个新的Rails项目,如下所示: $ rails new site 它执行并达到: bundle install 但是当我似乎尝试安装依赖项时出现了此错误 Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb checking for libkern/OSAtomic.h... yes creating Makefile make "DESTDIR=" clean make "DESTDIR=" compiling atomic_reference.c atomic_reference.c:57:59: warning: incompatible pointer types passing 'void **' to parameter of type 'volatile int64_t *' (aka 'volatile long long *') [-Wincompatible-pointer-types] if (OSAtomicCompareAndSwap64(expect_value, new_value, &DATA
  • 捆绑器为什么不安装JSON gem?(Why won't bundler install JSON gem?)
    问题 尝试运行cap production deploy时出现以下错误。 DEBUG [dc362284] Bundler::GemNotFound: Could not find json-1.8.1.gem for installation DEBUG [dc362284] An error occurred while installing json (1.8.1), and Bundler cannot continue. DEBUG [dc362284] Make sure that `gem install json -v '1.8.1'` succeeds before bundling. 可能需要注意的是,此部署正在工作,而不是我升级到Ruby 2.1.0来消除编码错误。 我在本地升级,效果很好。 我运行rvm install 2.1.0和rvm use 2.1.0然后更改了.ruby-version文件以反映此Ruby升级。 bundle install命令在本地工作,但是当我SSH到目标服务器并运行此命令时,会产生与上述相同的错误。 如果我运行gem list我可以在gem list中看到它。 ... jquery-rails (3.0.4) json (1.8.1) less (2.3.2) ... 如果我尝试推荐的解决方案gem install json
  • find_spec_for_exe':找不到宝石捆绑包(> = 0.a)(Gem :: GemNotFoundException)(find_spec_for_exe': can't find gem bundler (>= 0.a) (Gem::GemNotFoundException))
    问题 我使用sudo bundle install ,那可能是问题的原因吗? 我现在有: gem -v 2.6.14 ruby -v ruby 2.3.5p376(2017-09-14修订版59905)[x86_64-darwin15] jekyll -v jekyll 3.6.2 bundle -v Bundler版本1.16.0.pre.3 尝试运行bundle exec jekyll serve或仅jekyll serve时出现以下错误 /Users/myusername/.rvm/rubies/ruby-2.3.5/lib/ruby/site_ruby/2.3.0/rubygems.rb:271:in `find_spec_for_exe': can't find gem bundler (>= 0.a) (Gem::GemNotFoundException) from /Users/myusername/.rvm/rubies/ruby-2.3.5/lib/ruby/site_ruby/2.3.0/rubygems.rb:299:in `activate_bin_path' from /Users/myusername/.rvm/gems/ruby-2.3.5/bin/bundle:23:in `<main>' from /Users/myusername/.rvm
  • 您的Ruby版本是2.0.0,但是您的Gemfile指定了2.1.0(Your Ruby version is 2.0.0, but your Gemfile specified 2.1.0)
    问题 当我尝试捆绑安装时,出现以下消息: Your Ruby version is 2.0.0, but your Gemfile specified 2.1.0 在我的Gemfile中,我具有以下内容: ruby '2.1.0' 当我在控制台中运行ruby -v时,我得到: ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-darwin12.0] Ruby 2.1.0p0是什么意思? 我的Gemfile中应该具有哪个版本,为什么该错误告诉我我具有Ruby 2.0.0版本? 回答1 跑 gem install bundler 或者 gem update bundler 这可能会解决您的问题。 对于所有新安装的Ruby版本,您应该更新或安装新的捆绑程序。 回答2 在项目的顶级目录中,创建一个名为.ruby-version的文件,其中包含(等待它... ) 2.1.0 显然,这是现在指定版本的交叉{rbenv,rvm}方法。 回答3 如果您在Rails项目中获得此功能,并且最近升级了Ruby版本,则您的Spring可能仍与旧版本的Ruby一起运行。 ./bin/spring stop 将解决此问题。 回答4 对我而言,所有答案都无济于事。 我固定了它,然后关闭并再次打开终端。 回答5 没有其他建议对我有用。 在服务器上,我必须执行以下操作
  • 找不到Ruby捆绑包符号:_SSLv2_client_method(LoadError)(Ruby Bundle Symbol not found: _SSLv2_client_method (LoadError))
    问题 我正在尝试使用自制软件对openssl进行一些更新,但我设法以某种方式破坏了一切。 我现在什么也不能做,这是我尝试进行捆绑安装时得到的: $ bundle install /Users/asServer/.rbenv/versions/2.1.2/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': dlopen(/Users/asServer/.rbenv/versions/2.1.2/lib/ruby/2.1.0/x86_64-darwin13.0/openssl.bundle, 9): Symbol not found: _SSLv2_client_method (LoadError) Referenced from: /Users/asServer/.rbenv/versions/2.1.2/lib/ruby/2.1.0/x86_64-darwin13.0/openssl.bundle Expected in: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib in /Users/asServer/.rbenv/versions/2.1.2/lib/ruby/2.1.0/x86_64-darwin13.0/openssl.bundle -
  • 库未加载:/opt/local/lib/libssl.1.0.0.dylib(LoadError)(Library not loaded: /opt/local/lib/libssl.1.0.0.dylib (LoadError))
    问题 我只是发现我无法再进行gem push …进一步的挖掘使我不得不更新我的RVM SSL证书。 我运行了rvm osx-ssl-certs status all但是这给了我: /Users/davesag/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require': dlopen(/Users/davesag/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/2.0.0/x86_64-darwin12.4.0/openssl.bundle, 9): Library not loaded: /opt/local/lib/libssl.1.0.0.dylib (LoadError) Referenced from: /Users/davesag/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/2.0.0/x86_64-darwin12.4.0/openssl.bundle Reason: image not found - /Users/davesag/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/2.0.0/x86_64-darwin12.4.0
  • 'bundle exec' 抱怨 gem 没有被安装,即使在 'bundle install' 之后('bundle exec' complains about gem not being installed, even after 'bundle install')
    问题 我有一个使用 Jekyll 和 Github Pages 的网站。 之前在另一台计算机上搞乱了版本和 RVM 之后,在这台计算机上,我选择只使用一个版本的 Ruby 和使用捆绑程序的每个项目环境。 我有一个非常简单的Gemfile : [$]> cat Gemfile source 'https://rubygems.org' gem 'github-pages' 和捆绑器配置: [$]> cat .bundle/config --- BUNDLE_PATH: env BUNDLE_DISABLE_SHARED_GEMS: '1' 当我通过bundle exec运行任何命令(jekyll、gem、irb)时,出现依赖错误: [$]> bundle exec jekyll Could not find RedCloth-4.2.9 in any of the sources Run `bundle install` to install missing gems. 但是,该包已经安装: [$]> bundle install Using RedCloth 4.2.9 Using i18n 0.6.11 Using json 1.8.1 [snip] Using github-pages 29 Using bundler 1.7.7 Your bundle is complete
  • 安装原子时出错(Error Installing Atomic)
    问题 我正在尝试使用捆绑安装将gems安装到我的新Ruby项目中。 我已经在OS X 10.8.4机器上使用rbenv设置了Ruby的版本。 我收到以下错误: An error occurred while installing atomic (1.1.13), and Bundler cannot continue. Make sure that `gem install atomic -v '1.1.13'` succeeds before bundling. Kikime:jazzcatalog curt$ gem install atomic Building native extensions. This could take a while... Successfully installed atomic-1.1.13 1 gem installed Kikime:jazzcatalog curt$ rbenv rehash Kikime:jazzcatalog curt$ bundle install Fetching gem metadata from https://rubygems.org/......... Fetching gem metadata from https://rubygems.org/.. Using rake (10.1.0) Using
  • Ruby on Rails 无法捆绑安装(Ruby on Rails cannot bundle install)
    问题 红宝石版本:2.1.5p273 导轨版本:4.2.0 宝石版本:2.2.2 操作系统:Windows 7 x64 您好,我对 Rails 编程非常陌生。 我正在尝试开始学习,但不能因为这些问题。 我创建了一个 rails 应用程序我输入:> rails new app 然后我导航到创建的文件夹我输入:>rails 服务器它告诉我 “运行‘捆绑安装’来安装丢失的 gem。” 我这样做了,它告诉我: “确保'gem install debugger-linecache -v '1.2.0' 在打包前成功” 安装上述 gem 后,我再次尝试 bundle install,但它会用不同的 gem 重复相同的错误。 ""Make sure that 'gem install *random gem* -v '*random version*' succeeds before bundling'"" 我几乎不知道我在这里做什么。 我怎样才能让这个服务器运行? 回答1 我开始写一个答案,然后看到你评论, 但是对于需要答案但没有注意到您的评论的每个人: 试试这个, 第一次运行: bundle update 然后尝试bundle install 如果它不起作用,请安装捆绑程序: gem install bundler 现在运行bundle install 回答2 使用以下两个命令解决:
  • 如何安装本地gem?(How can I install a local gem?)
    问题 如果我将.gem文件下载到计算机中的文件夹中,以后可以使用gem install安装它吗? 回答1 是的,当您执行gem install ,它将首先搜索当前目录,因此,如果您的.gem文件在那里,它将进行选择。 我在gem参考上找到了它,您也可能会发现它很方便: gem install将安装命名的gem。 它将尝试本地安装(即当前目录中的.gem文件),如果失败,它将尝试下载并安装所需的gem的最新版本。 回答2 另外,您可以使用gem install --local path_to_gem/filename.gem 这将跳过掉--local时发生的常规gem仓库扫​​描。 您可以使用gem install --help找到其他魔术。 回答3 您还可以将完整文件名用于gem文件: gem install /full/path/to/your.gem 这也很好-这可能是最简单的方法 回答4 如果使用捆绑器创建宝石: # do this in the proper directory bundle gem foobar 编写它们后,可以使用rake安装它们: # cd into your gem directory rake install 您下载的gem可能也会知道rake install 。 回答5 如果您是从github或其他scm主机站点下载项目文件,请首先使用gem
  • 软件包安装失败,并显示SSL证书验证错误(bundle install fails with SSL certificate verification error)
    问题 当我在Centos 5.5上为Rails 3项目运行bundle install ,它失败并出现错误: Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (https://bb-m.rubygems.org/gems/multi_json-1.3.2.gem) An error occured while installing multi_json (1.3.2), and Bundler cannot continue. Make sure that `gem install multi_json -v '1.3.2'` succeeds before bundling. 当我尝试手动安装gem时(通过gem install multi_json -v '1.3.2' ),它可以工作。 其他几个宝石也会发生相同的问题。 我使用RVM(1.12.3),ruby 1.9.2,bundler 1.1.3。 如何解决? 回答1 更新 现在,我已经从这个答案中充分挖掘了..err,每个人都应该知道应该已经解决了这个问题。 回复:再次通过Ownatik捆绑安装失败
  • 捆绑程序:找不到命令(Bundler: Command not found)
    问题 我在 vps、ubuntu 10.04、rails 3、ruby 和 mysql 上托管,按照一些教程正确安装。 如果我运行bundle check或bundle install我会收到错误“-bash: bundle: command not found”。 从gem list --local我看到安装了“bundler (1.0.2, 1.0.0)”。 我不知道怎么回事... gem environment返回: RubyGems Environment: - RUBYGEMS VERSION: 1.3.7 - RUBY VERSION: 1.8.7 (2010-04-19 patchlevel 253) [i686-linux] - INSTALLATION DIRECTORY: /opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8 - RUBY EXECUTABLE: /opt/ruby-enterprise-1.8.7-2010.02/bin/ruby - EXECUTABLE DIRECTORY: /opt/ruby-enterprise-1.8.7-2010.02/bin - RUBYGEMS PLATFORMS: - ruby - x86-linux - GEM PATHS: - /opt/ruby
  • 当我运行捆绑安装时,Nokogiri'无法构建gem本机扩展'(Nokogiri 'Failed to build gem native extension' when I run bundle install)
    问题 我正在运行bundle install ,但出现此错误: Building nokogiri using system libraries. Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb --use-system-libraries Building nokogiri using system libraries. libxml2 version 2.6.21 or later is required! *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options. Provided configuration options: --with-opt-dir --without-opt-dir -
  • 捆绑安装错误:源不包含任何版本的(Bundle install error: Source does not contain any versions of)
    问题 我的 gem 文件包含: gem "breadcrumb", :git => "git@github.com:mjacobus/Breadcrumb.git" gem "simple_menu", :git => "git@github.com:mjacobus/simple_menu.git" 第一个 gem 按预期安装,但第二个安装失败。 Updating git@github.com:mjacobus/simple_menu.git Fetching gem metadata from https://rubygems.org/........ Could not find gem 'simple_menu (>= 0) ruby' in git@github.com:mjacobus/simple_menu.git (at master). Source does not contain any versions of 'simple_menu (>= 0) ruby' 类似的帖子指出缺少 .gemspec 文件,但该文件存在。 https://github.com/mjacobus/simple_menu/blob/master/simple_menu.gemspec 我可能正在做一些别人的眼睛能够看到的愚蠢的事情。 编辑 我将 repo 克隆到 vendor
  • Gemfile在rails中有什么用?(What is the use of Gemfile in rails?)
    问题 Gemfile在rails中有什么用? 如何使用Gemfile ? 回答1 在Rails开发过程中,有时您会想要提供一些您需要的功能,但是您要么不知道该怎么做,要么就不想自己实现它,因为很多有才华的开发人员已将其工作投入开发。 您可能需要的这些开发(用户身份验证,消息系统,资产处理程序,地理位置,分页系统,链接到外部服务(例如Amazon AWS)以及最后但并非最不重要的Rails本身)被称为Ruby Gems。 这些是ruby软件包,不一定与Rails有关,但是由于Rails基于Ruby,因此98%的gem可以用于Rails Web应用程序代码。 可以在github中找到很多宝石,但是通过ruby-gems或ruby-toolbox搜索宝石的乐趣很大 gemfile是要包含在项目中的所有gem的列表。 它与捆绑程序(也是宝石)一起使用,以安装,更新,删除和管理您使用过的宝石。 gemfile另一个用途是-您可以在:development , :test , :assets , :production等组中对gem进行分组,Rails会知道何时包括这些gem。 例如: group :development, :test do gem "rspec-rails" gem "factory_girl_rails" gem "guard-rspec" end 请注意,在Rails
  • 没有随 debugger-ruby_core_source gem 提供的 ruby​​-2.0.0-p451 源(No source for ruby-2.0.0-p451 provided with debugger-ruby_core_source gem)
    问题 我在其他 SO 问题(例如 debugger-ruby_core_source gem 提供的 ruby​​-1.9.2-p321 没有来源)以及通过 Google 搜索中看到了非常相似的问题,但到目前为止这些问题都没有帮助。 我正在使用 OSX Mavericks(第一次使用 mac 用户)和 rbenv(第一次使用它)。 我已经 git 克隆了一个 Rails 项目,我之前在另一台笔记本电脑(Ubuntu 和 rvm)上运行过这个项目。 rbenv version :2.0.0-p451(我手动安装) 当我尝试bundle install ,我得到以下信息: ... Using debugger-ruby_core_source (1.3.1) Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /Users/macuser/.rbenv/versions/2.0.0-p451/bin/ruby extconf.rb checking for rb_method_entry_t.called_id in method.h... no checking for rb_control_frame_t.method_id in method.h... no