天道酬勤,学无止境

将 rvm 从 .rvmrc 转换为 .ruby-version 后未收到信息消息(Not getting info message after converting rvm from .rvmrc to .ruby-version)

问题

我刚刚在几个项目中运行rvm rvmrc 到 ruby​​-version 。 查看生成的文件,它们匹配谷歌搜索中应该包含的内容(.ruby-version 和 .ruby-gemset)。

当我 cd 进入项目目录时,我不再收到Using /home/ /.rvm/gems/ruby-1.9.3-p392 with gemset info 消息。

有没有办法让信息消息回来?

谢谢。

回答1

运行应该足够了:

echo rvm_use_flag=2 >> ~/.rvmrc

它会告诉 RVM 始终显示消息(它不适用于一些不支持它的旧项目.rvmrc文件)。

标签

受限制的 HTML

  • 允许的HTML标签:<a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type> <li> <dl> <dt> <dd> <h2 id> <h3 id> <h4 id> <h5 id> <h6 id>
  • 自动断行和分段。
  • 网页和电子邮件地址自动转换为链接。

相关推荐
  • 使用rvmrc或ruby-version文件通过RVM设置项目gemset?(Use rvmrc or ruby-version file to set a project gemset with RVM?)
    问题 我使用RVM,Ruby版本管理器为我的每个Rails项目指定一个Ruby版本和一组gem。 我有一个.rvmrc文件,可以在每次cd进入项目目录时自动选择Ruby版本和gemset。 安装RVM 1.19.0后,我收到一条消息 您正在使用.rvmrc ,它需要信任,速度较慢,并且与其他ruby管理器不兼容,您可以使用rvm rvmrc to [.]ruby-version切换到.ruby-version rvm rvmrc to [.]ruby-version或rvm rvmrc to [.]ruby-version或通过rvm rvmrc warning ignore /Users/userName/code/railsapps/rails-prelaunch-signup/.rvmrc忽略此警告rvm rvmrc warning ignore /Users/userName/code/railsapps/rails-prelaunch-signup/.rvmrc , .rvmrc仍将是默认的项目文件中RVM 1和2 RVM,对所有文件运行忽略警告rvm rvmrc warning ignore all.rvmrcs 。 我应该继续使用.rvmrc文件还是应该切换到.ruby-version文件? 哪个是最佳的? 有哪些后果? 回答1 如果您的
  • 我应该输入`.ruby-gemset`和/或`.ruby-version`吗?(Should I check in `.ruby-gemset` and/or `.ruby-version`?)
    问题 我刚刚更新了RVM,并代替了旧的.rvmrc ,它自动创建了.ruby-gemset和.ruby-version 。 我一直都有.rvmrc文件,其内容类似于rvm use --create default@project_name 。 但是, .ruby-version包含我正在运行的特定Ruby版本,而不是default 。 我很乐意签入。 另外,我在播客上听到有人说,不应该签入.ruby-gemset因为其他人可能对如何命名.ruby-gemset有自己的偏好。 我什么时候应该或不应该签入.ruby-gemset和/或.ruby-version ? 具体来说: 权衡有哪些? 项目类型如何影响决策(例如,应用程序vs宝石)? 如果应将其检入,项目类型如何影响这些文件中应包含的内容? 来自rvm,rbenv等工具的创建者的引用将得到解答。 回答1 对于标准项目 如果您的项目依赖于ruby-2.0.0类的ruby-2.0.0请.ruby-version入.ruby-version 。 仅在您的团队同意后才能.ruby-gemset入.ruby-gemset 。 将.rvmrc添加到.gitignore以便任何人都可以使用.rvmrc覆盖.ruby-*文件设置。 对于宝石 仅当您的项目仍以ruby 1.8.7目标时,才使用ruby-1.8.7检入.ruby-version
  • Use rvmrc or ruby-version file to set a project gemset with RVM?
    I use RVM, the Ruby Version Manager to specify a Ruby version and a set of gems for each of my Rails projects. I have a .rvmrc file to automatically select a Ruby version and gemset whenever I cd into a project directory. After installing RVM 1.19.0, I get a message You are using .rvmrc, it requires trusting, it is slower and it is not compatible with other ruby managers, you can switch to .ruby-version using rvm rvmrc to [.]ruby-version or ignore this warnings with rvm rvmrc warning ignore /Users/userName/code/railsapps/rails-prelaunch-signup/.rvmrc, .rvmrc will continue to be the default
  • Not getting info message after converting rvm from .rvmrc to .ruby-version
    I've just run rvm rvmrc to ruby-version on a couple of projects. Looked at the produced files, they match what googling says should be in them (.ruby-version & .ruby-gemset). When I cd into the project directories, I no longer get the Using /home/user/.rvm/gems/ruby-1.9.3-p392 with gemset projectname info message. Is there any way for get info message back? Thanks.
  • 尝试使用capistrano进行部署时,为什么会出现Psych错误?(Why am I getting a Psych error when trying to deploy with capistrano?)
    问题 我目前正在我的Rails 3.2.13应用程序中设置capistrano。 我收到以下错误/详细信息(包括“第1行第1列不允许使用控制字符”)。 我已经为此进行了一些搜索,但是没有看到任何与我相关的信息。 我正在使用rvm-capistrano和ruby 2.0.0-p195。 最近,我将应用程序所需的环境变量移到了.bashrc中。 ... * 2013-06-10 15:18:32 executing `deploy:assets:update_asset_mtimes' * executing "[ -e /home/deployer/apps/super_rad_app/shared/assets/manifest* ] && cat /home/deployer/apps/super_rad_app/shared/assets/manifest* || echo" servers: ["107.20.249.163"] [107.20.249.163] executing command command finished in 6238ms *** [deploy:update_code] rolling back * executing "rm -rf /home/deployer/apps/super_rad_app/releases
  • 使用 rvm 创建 .ruby-version 和 .ruby-gemset(Create .ruby-version and .ruby-gemset with rvm)
    问题 在创建新的 gemset 时,有没有办法创建关联的.ruby-version和.ruby-gemset文件? 对于旧版本的 rvm,可以执行rvm --create --rvmrc 1.8.7@project ,但这会创建.rvmrc文件。 我以为我在某个地方读到了我们可以使用--ruby-version命令行开关的地方,但是我这样做没有成功。 回答1 我最近遇到了同样的问题。 rvm --help引导我: rvm --create --ruby-version ruby-1.9.3@my-gemset 它创建了.ruby-gemset和.ruby-version 。 回答2 根据官方 RVM 文档,您可以使用: echo 1.9.3 > .ruby-version 或者你可以使用这个: rvm --ruby-version use 1.9.3@my_app 第二种形式将创建.ruby-version和.ruby-gemset 。 回答3 假设我正在为名为tptapp 的rails 应用程序创建 gemset,那么我们可以通过以下方式进行操作。 rvm use 2.2.2@tptapp --create 这里tptapp是 gemset 的名称,2.2.2 是 Ruby 版本。 回答4 以上所有示例都要求您输入您的 ruby​​ 版本和 gemset 名称 .. 这与 vi
  • pow 说:Bundler::GemNotFound:在任何来源中都找不到 rake-0.9.2.2(pow says: Bundler::GemNotFound: Could not find rake-0.9.2.2 in any of the sources)
    问题 我有一个轨道运行与精细的应用程序rails s ,但是当我尝试使用POW我得到这个错误加载它: Bundler::GemNotFound: Could not find rake-0.9.2.2 in any of the sources ~/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.22/lib/bundler/spec_set.rb:88:in `block in materialize' ~/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.22/lib/bundler/spec_set.rb:82:in `map!' ~/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.22/lib/bundler/spec_set.rb:82:in `materialize' .... 奇怪的是,此应用程序中的.rvmrc文件指定1.9.3-p125 : which rake .../.rvm/gems/ruby-1.9.3-p125/bin/rake 这是我运行bundle install时看到的内容: Using rake (0.9.2.2) FWIW,pow与使用1.9.2和其他gemset的另一个非Rails项目很好地配合。 谢谢! 回答1 我猜你更新了
  • 为什么我在任何来源中都找不到 multi_json-1.3.1?(Why I am getting Could not find multi_json-1.3.1 in any of the sources?)
    问题 我有一个简单的 Rails 应用程序,我想部署到 Heroku。 当我运行以下命令时 git push heroku master 显示以下错误消息。 Could not find multi_json-1.3.1 in any of the sources ! ! Failed to install gems via Bundler. ! ! Heroku push rejected, failed to compile Ruby/rails app 这是我的 Gemfile gem 'rails', '3.2.3' gem 'pg' group :assets do gem 'sass-rails', '~> 3.2.3' gem 'coffee-rails', '~> 3.2.1' gem 'therubyracer', :platform => :ruby gem 'uglifier', '>= 1.0.3' end gem 'jquery-rails' 回答1 删除 Gemfile.lock 文件,然后运行 ​​bundle install。 这对我有用! 回答2 尽管我知道这些 gems 可用,但我还是看到了针对不同 gem 的一系列这些错误(例如gem list -r <gem>显示它们,包括版本;浏览 ruby​​gems.org
  • Ruby on Rails Mac OSX Mavericks issues after RVM install
    I have been learning Ruby on Rails for a couple of months, and everything was working. Then, for the needs of a tutorial, I tried to install RVM, in order to downgrade my setup to older versions of Ruby and Rails. And since then, I kept running into troubles. For instance, anytime I launch a new Terminal session, here is what I get: You are using '.rvmrc', it requires trusting, it is slower and it is not compatible with other ruby managers, you can switch to '.ruby-version' using 'rvm rvmrc to [.]ruby-version' or ignore this warning with 'rvm rvmrc warning ignore /Users/Thibaud/work/.rvmrc', '
  • 忽略 GEM,因为它的扩展没有构建(Ignoring GEM because its extensions are not built)
    问题 在我的工作和家用计算机上,我最近使用ruby-install将 Ruby 升级到 2.3.1。 我使用chruby作为我的 Ruby 切换器。 我开始在终端中看到此警告: Ignoring bcrypt-3.1.11 because its extensions are not built. Try: gem pristine bcrypt --version 3.1.11 Ignoring bcrypt-3.1.10 because its extensions are not built. Try: gem pristine bcrypt --version 3.1.10 Ignoring binding_of_caller-0.7.2 because its extensions are not built. Try: gem pristine binding_of_caller --version 0.7.2 Ignoring byebug-9.0.5 because its extensions are not built. Try: gem pristine byebug --version 9.0.5 Ignoring byebug-5.0.0 because its extensions are not built. Try: gem pristine
  • Create .ruby-version and .ruby-gemset with rvm
    Is there a way to create the associated .ruby-version and .ruby-gemset files when creating a new gemset? With older versions of rvm, one could do rvm --create --rvmrc 1.8.7@project, but that creates .rvmrc files. I thought I read somewhere we could use the --ruby-version command line switch, but I have been unsuccessful in doing so.
  • Should I check in `.ruby-gemset` and/or `.ruby-version`?
    I've just updated RVM, and in place of the old .rvmrc, it auto-created .ruby-gemset and .ruby-version. I've always had .rvmrc files with contents like rvm use --create default@project_name. However, .ruby-version contains the specific Ruby version I'm running rather than default. I'm hesitant to check this in. Also, I heard someone say on a podcast that one shouldn't check in .ruby-gemset because others may have their own preferences about how to name gemsets. When should or shouldn't I check in .ruby-gemset and/or .ruby-version? Specifically: What are some of the tradeoffs? How does the type
  • Bundler :: RubyVersionMismatch:您的Ruby版本是1.9.3,但是您的Gemfile指定了2.0.0(Bundler::RubyVersionMismatch: Your Ruby version is 1.9.3, but your Gemfile specified 2.0.0)
    问题 我将Mac与Pow,Ruby,Rails和许多有用的宝石一起使用。 每当我尝试打开我的应用程序时,我都会收到此错误。 Bundler :: RubyVersionMismatch:您的Ruby版本是1.9.3,但是您的Gemfile指定了2.0.0 我理解该错误,但是在这里找不到为什么它没有使用正确的版本。 一些有用的信息: 堆栈跟踪 Bundler::RubyVersionMismatch: Your Ruby version is 1.9.3, but your Gemfile specified 2.0.0 ~/.rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/definition.rb:361:in `validate_ruby!' ~/.rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler.rb:116:in `setup' ~/.rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/setup.rb:17:in `<top (required)>' ~/Dropbox/Documents/project/Sites/project-profile/config.ru:3:in
  • 如何使用 RVM 管理多个 gemset 和 ruby​​ 版本?(How to manage multiple gemsets and ruby versions with RVM?)
    问题 我真的对 RVM 网站上给出的解释感到困惑。 我不清楚不同 ruby​​ 解释器和 gemset 之间的关系。 在我看来,是这样的—— 我的 Mac 帐户有一个 rvm 该 rvm 安装和管理一组不同版本的 ruby​​ 解释器。 每个 ruby​​ 版本都有一套 gemsets。 我把事情说清楚了吗……欢迎更多的解释。 我可以从事(Ruby 1.8.7 + rails 2.3.8 及其依赖项)和(Ruby 1.9.2 和 Rails 3.0 及其依赖项)... 如果有人精通在 rvm 的帮助下处理许多 ruby​​ 版本和 gemsets,请向我解释......感谢您的帮助 回答1 这是我喜欢这样做的方式... 使用 RVM 安装 ruby 切换到/使用那个红宝石为项目创建 gemset 切换到/使用该 gemset 安装所需的宝石创建一个指向我选择的 ruby​​ 和 gemset 的别名切换到/使用该新别名(同样,与项目相关联) 对于您希望彼此分开的不同项目,请根据需要多次执行此操作。 例子: $ rvm install ruby-1.9.2 ... $ rvm list rvm rubies => ree-1.8.7-head [ i386 ] ruby-1.9.2-head [ i386 ] ruby-1.9.2-preview3 [ i386 ] $ rvm
  • 在 Mac 10.7 上运行“requirements_osx_brew_libs_install...”时出错(Error running 'requirements_osx_brew_libs_install…' on Mac 10.7)
    问题 尝试在上一代 Macbook Pro 上安装 brew 并不断收到以下错误: 运行“requirements_osx_brew_libs_install autoconf automake libtool pkg-config apple-gcc42 libyaml readline libxml2 libxslt libksba openssl sqlite”时出错, 请阅读/Users/allegrascrugham/.rvm/log/ruby-1.9.3-p392/1368142352_package_install_autoconf_automake_libtool_pkg-config_apple-gcc42_libyaml_readline_libxml2_libxslt_libksba_openssl_sqlite。 我尝试删除并重新安装 RVM & Brew,但没有成功。 回答1 运行rvm requirements时我遇到了完全相同的错误。 除了安装包失败之外,该日志文件没有给出任何提示。 这对我有用: 在它失败之前从最后一个包开始,在你的情况下sqlite 。 然后像这样手动安装: brew install sqlite 然后再次运行rvm requirements ,它可能会在较早的包中失败。 重复以上步骤。 回答2 您必须手动安装这些依赖项,请尝试
  • 警告! PATH设置不正确,通常是由Shell初始化文件引起的(Warning! PATH is not properly set up, usually this is caused by shell initialization files)
    问题 每当我进入带有.rvmrc文件的文件夹时,都会出现警告: Warning! PATH is not properly set up, '/home/me/.rvm/gems/ruby-2.0.0-p247/bin' is not available, usually this is caused by shell initialization files - check them for 'PATH=...' entries, to fix run: 'rvm use ruby-2.0.0-p247'. 我确实rvm use ruby-2.0.0-p247 ,但是警告仍然存在。 注意:没有错误,我可以正常运行我的应用程序,但是警告很烦人。 有任何想法吗? 回答1 这是一个错误,已通过https://github.com/wayneeseguin/rvm/issues/2050处理,并以rvm稳定版本1.21.15于2013-07-29 19:15:30 -0700发布 回答2 即使将RVM升级到1.25.16版,我也收到相同的警告。 我能够通过运行以下命令来修复警告: rvm reset 然后,当我跑步时: rvm version 我再也没有收到错误。 希望这可以帮助! 回答3 如果您知道自己在做什么,并且将PATH设置为所需的内容,则可以通过在~/
  • 如何从Ubuntu删除Ruby(How to remove Ruby from Ubuntu)
    问题 我要删除Ruby,因此尝试此操作。 我该如何删除? sudo apt-get autoremove ruby Reading package lists... Done Building dependency tree Reading state information... Done Package 'ruby' is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 534 not upgraded. here@jaskaran:/$ whereis ruby ruby: /usr/bin/ruby /usr/lib/ruby /usr/bin/X11/ruby /usr/share/man/man1/ruby.1.gz here@jaskaran:/$ ruby -v ruby 1.9.3p194 (2012-04-20 revision 35410) [i686-linux] 回答1 Ubuntu ...? 使用它来找出您正在运行的可执行文件: $ which ruby /usr/bin/ruby 使用它来找出实际上是什么: $ readlink -f /usr/bin/ruby /usr/bin/ruby1.8 使用它来找出它属于哪个包: $ dpkg -S
  • How to fix “Your Ruby version is 1.9.3, but your Gemfile specified 2.0.0”(How to fix “Your Ruby version is 1.9.3, but your Gemfile specified 2.0.0”)
    问题 我创建了一个Ruby项目,但是在运行bundle update和bundle install它返回错误: Your Ruby version is 1.9.3, but your Gemfile specified 2.0.0 它的图片是:http://i.imgur.com/dZMhI11.png?1 我的gemfile是: ruby '2.0.0' #ruby-gemset=railstutorial_rails_4_0 gem 'rails', '4.0.0' group :development do gem 'sqlite3', '1.3.8' end gem 'sass-rails', '4.0.0' gem 'uglifier', '2.1.1' gem 'coffee-rails', '4.0.0' gem 'jquery-rails', '3.0.4' gem 'turbolinks', '1.1.1' gem 'jbuilder', '1.0.2' group :doc do gem 'sdoc', '0.3.20', require: false end 回答1 如果运行ruby -v您将看到已经安装了Ruby 1.9.3,但是Gemfile中的第一行指定您要使用Ruby 2.0.0。 您应该安装Ruby 2.0
  • RVM和Jenkins设置(RVM and Jenkins setup)
    问题 我是Jenkins CI的新手。 我在远程Jenkins中以及在shell下执行时安装RVM。 #!/bin/bash -x source ~/.bashrc rvm use 1.9.3@rails-3.2.3 我收到以下错误。 + source /var/lib/jenkins/.bashrc ++ PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/var/lib/jenkins/.rvm/bin:/var/lib/jenkins/.rvm/bin + rvm use 1.9.3@rails-3.2.3 RVM is not a function, selecting rubies with 'rvm use ...' will not work. You need to change your terminal settings to allow shell login. Please visit https://rvm.io/workflow/screen/ for example. 这是什么意思? 我不知道请帮我。 更新:我尝试下面的脚本,但仍然出现错误: #!/bin/bash -x source /home/zeck/.bashrc [[ -s ".rvmrc" ]] && source
  • “你的 Ruby 版本是 1.9.3,但你的 Gemfile 指定了 1.9.3-p194”(“Your Ruby version is 1.9.3, but your Gemfile specified 1.9.3-p194”)
    问题 RVM 不会让我运行bundle因为它认为我的 Ruby 版本与我的 Gemfile 所说的不同,但事实并非如此: $ rvm list rvm rubies => ruby-1.9.3-p194 [ x86_64 ] ruby-1.9.3-p429 [ x86_64 ] * ruby-2.0.0-p195 [ x86_64 ] # => - current # =* - current && default # * - default $ ruby -v ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin13.0.0] 宝石档案: ruby '1.9.3-p194' 但是之后: $ bundle install Your Ruby version is 1.9.3, but your Gemfile specified 1.9.3-p194 $ 这似乎是一件非常奇怪的事情。 有任何想法吗? 有这个疑问的人很多,但是他们的Gemfiles和运行的版本明显不同。 我什至完成了rvm use 1.9.3-p194 ,然后在bundle install之后立即完成,但我得到了同样的错误。 bundle update产生相同的错误。 如果我从 Gemfile 中删除 ruby​​ 版本,它将默认为 2.0.0