天道酬勤,学无止境

How do you add a ruby file to an existing project in Eclipse 3.6 using the Dynamic Languages Toolkit (DLTK)?

I've installed the Dynamic Languages Toolkit (DLTK) in Eclipse 3.6. But I can't figure out how to create a Ruby file in an existing Java project.

Doing the obvious thing (New -> Empty Ruby Script) just gives the error message "Source folder is not a correct project". Do I have to modify the project in some way to tell DLTK that it's OK to add Ruby files to it?

(Adding the file outside of Eclipse does work.)

标签

评论

Do the following steps (has worked for me):

  1. Create a java project, or visit an existing one.
  2. Select in the directory you want the ruby file to live in the menu entry New file and enter in the dialog the filename my_file.rb. The essential part is the extension, because this will ensure that the ruby mechanisms are in place.
  3. Enter in the new ruby file def and press CTRL-SPACE, you should see as a result the list with def - method definition (the template), def and defined?. This is all part of the ruby text editor.

So it is possible to mix java and ruby files in the same project, that has as nature java. The only thing I has noticed is that the run menu entry only allows you to start the dialog Run As > Run Configurations... and enter there the necessary parameters to start your ruby script.

受限制的 HTML

  • 允许的HTML标签:<a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type> <li> <dl> <dt> <dd> <h2 id> <h3 id> <h4 id> <h5 id> <h6 id>
  • 自动断行和分段。
  • 网页和电子邮件地址自动转换为链接。

相关推荐
  • 帮助为 Eclipse 设置 php(Help setting up php for Eclipse)
    问题 我正在尝试为 php web 开发设置 Eclipse。 我想做的是从 Eclipse 中预览一个 php 网页,但我不知道如何做到这一点。 是否有某种类型的集成 Web 服务器允许这样做,或者我是否必须设置 IIS/Apache 才能做到这一点? 如果是这样,我是否必须将我的 php 文件放在 web 服务器路径中,或者 Eclipse 是否自动将文件部署到本地 web 服务器? 任何信息或链接将不胜感激。 回答1 Eclipse 有一个名为 PDT 的插件,它使 PHP 开发变得轻而易举。 有关如何安装它的概述,您可以参考 Eclipse 网站: http://wiki.eclipse.org/PDT/Installation#Eclipse_3.4_.2F_Ganymede_.2F_PDT_2.0 要实际查看运行的 PHP 脚本,我想您必须已经安装并运行某种服务器。 您可以将工作区位置设置在服务器路径中,然后通过 localhost 查看文件。 但也许 PDT 包会为您处理其中的一些问题。 回答2 我会让它很容易;) (1) 进入 Eclipse 主页:http://www.eclipse.org/downloads/ 并下载 Eclipse Classic(当前 May/2013 版本为 4.2.2) (2) 在你的机器上启动了 eclipse 执行以下操作:帮助 >
  • 如何在Eclipse中使用Tomcat 8?(How to use Tomcat 8 in Eclipse?)
    问题 EDIT 2014-02-07:Eclipse Luna在这里,捆绑的WTP中包括对Tomcat 8的支持:)开心的日子! Tomcat 8仍在开发中,但是您可以在此处获得它。 现在,Apache Tomcat主页上有一个RC版本。 更新2/27/14:8已发布,并且为WTP构建的适配器尚未集成到Eclipse捆绑包中。 很快! 但是,在Eclipse Kepler中,Tomcat 8的添加服务器列表中没有受支持的适配器。Tomcat7适配器不起作用,并且看起来好像没有新的扩展程序可供其在“安装新扩展程序”中下载。对话。 我唯一的选择是让它(Tomcat 8)在Eclipse之外本地运行,并可能将远程调试器挂接到其中以单步执行代码? Eclipse Kepler + Tomcat 8还能使用吗? 我进入那条路径的30分钟时间内,IntelliJ IDEA 12无法做到这一点。 如果您想知道为什么我要尝试这样做,那么我正在玩Spring 4.0.0.M1和4.0.0.M2 WebSocket。 他们(根据Rossen Stoyanchev的Spring 4.0博客文章和示例)使用JSR-356,它在Tomcat 8中实现,理论上可以在某个时候反向移植到Tomcat 7。 回答“我如何轻松获得支持Spring 4 WebSocket的开发环境?”这一更广泛的问题的答案。 会很好
  • 在 Openshift 中部署现有应用(Deploy an existing app in Openshift)
    问题 我创建了一个网络应用程序,我想在 Openshift 上部署。 最简单的方法是什么? 我正在使用 Openshift Eclipse 客户端。 我应该创建一个新的 openshift,然后从我现有的应用程序中复制所有文件,还是有更简单的方法将我现有的应用程序转换为 openshift 应用程序? 谢谢 回答1 如果您的应用程序是 Java EE Web 应用程序,请尝试以下操作: http://jaitechwriteups.blogspot.com.br/2011/08/deploy-java-ee-application-on-openshift.html https://openshift.redhat.com/community/forums/express/how-can-i-deploy-a-war 回答2 我认为使用 OpenShift 的最佳方式是通过 rhc 命令行结合 git。 设置完成后,您可以轻松地将 git push 推送到 OpenShift 并使用操作挂钩控制应用程序的部署。 查看带有 Python Django 应用程序的 OpenShift 示例:https://github.com/openshift/django-example 以及您可以在此处找到的操作挂钩:https://github.com/openshift/django
  • 如何让 Java Decompiler / JD / JD-Eclipse 在 Eclipse Helios 中运行(How to get Java Decompiler / JD / JD-Eclipse running in Eclipse Helios)
    问题 Java Decompiler (JD) 通常被推荐为一个很好的 Java Decompiler。 JD-Eclipse 是 JD 的 Eclipse 插件。 我在几台不同的机器上遇到问题来运行插件。 每当我尝试打开 .class 文件时,标准的“未找到源”编辑器都会显示,显示低级字节码反汇编,而不是您期望从反编译器获得的 Java 源输出。 http://java.decompiler.free.fr/?q=jdeclipse 中的安装文档还不错,但在故障排除方面相当模糊。 开这个问题收集补充资料:你在Eclipse Helios运行京东之前遇到过哪些问题? 解决方案是什么? 回答1 这是我遇到的东西: 1) RTFM 并安装安装文档顶部提到的“Microsoft Visual C++ 2008 SP1 Redistributable Package”。 起初我错过了这一点,因为 Helios 说明在最后。 2) 在打开类文件之前关闭所有打开的编辑器选项卡。 否则很容易从以前的尝试中获得过时的编辑器选项卡。 3) 在“Java 类文件编辑器”(不是“Java 类文件查看器”)中打开类文件。 使用上下文菜单中的“打开方式”获得正确的编辑器。 如果对结果感到满意,请将其设为文件关联设置中的默认编辑器,在窗口/首选项常规/编辑器/文件关联中选择 *.class 以使用“Java
  • 如何将 Eclipse 用于 Ruby on Rails (RoR)(How to use Eclipse for Ruby on Rails (RoR))
    问题 我是 Ruby 新手。 我已经在 Windows 7 上安装了 Ruby on Rails。我访问了以下内容以选择合适的 IDE/编辑器来编写 Ruby 代码: http://rubyonrails.org/download 我找到了以下 Ruby 编辑器: VIM for Rails、RadRails、RubyMine、3rd Rail、Netbeans for Ruby 我熟悉 Eclipse,因为我将 Eclipse 用于 Java。 我可以将 Eclipse 用于 Ruby 吗? 如果是这样,Eclipse 的 Ruby 项目需要什么配置? 回答1 为了节省您的一些麻烦,在 Eclipse 中: 转到帮助 -> 安装新软件... 单击添加(弹出窗口的右上角) 输入一个名称,如“RadRails2” 输入位置为 http://download.aptana.com/tools/radrails/plugin/install/radrails-bundle(对于完整的 Aptana studio Studio 3,请输入 http://download.aptana.com/studio3/plugin/安装) 单击确定重启 Eclipse 转到窗口 -> 首选项。 您将在左侧面板中看到 Ruby 已登记 你完成了... 现在,当您使用“新建”菜单时,您将可以选择创建
  • 您更喜欢哪种Ruby IDE? [关闭](What Ruby IDE do you prefer? [closed])
    问题 从目前的情况来看,这个问题不适合我们的问答形式。 我们希望答案得到事实,参考或专业知识的支持,但是这个问题可能会引起辩论,争论,民意测验或进一步的讨论。 如果您认为此问题可以解决并且可以重新提出,请访问帮助中心以获取指导。 9年前关闭。 已锁定。 该问题及其答案被锁定,因为该问题是题外话,但具有历史意义。 它目前不接受新的答案或互动。 我最近将Eclipse与RDT(不是RadRails)一起使用了很多,对此我感到很满意,但是我想知道你们是否知道任何不错的选择。 我知道NetBeans现在也支持Ruby,但是我不确定它在Eclipse上提供了什么。 请列出您认为在建议IDE时出色或有用的所有功能,以便于比较。 另外,我说的是Ruby,而不是Rails。 尽管对Rails的支持是一个加号,但我更喜欢以Rails为中心的东西。 它也应该在Linux和Solaris(可选)上可用。 回答1 您尝试过Aptana吗? 它基于Eclipse,并且有一个不错的Rails插件。 回答2 来自JetBrains的RubyMine。 (也可以作为IntelliJ IDEA的插件使用) 回答3 最近,雷德卡(Redcar)也引起了人们的注意。 仍然处于生命的早期,但它显示出了希望。 回答4 在Mac OS X上,TextMate是天赐之物。 回答5 最新的Netbeans IDE(6.1
  • 引用另一个 Java 项目的 Java Web 项目(Java Web Project referencing another Java project)
    问题 我有一个Java Project ,我现在正在为它创建一个 Web 界面,使用来自 Eclipse 的Dynamic Web Project 。 Web 项目由一个servlet和两个JSP 。 像这样的东西: /JavaApplication /src /lib /resources /WebApplication /src /Servlet.java /WebContent /WEB-INF index.jsp other.jsp 现在,我需要从WebApplication引用JavaApplication ,以便使用它的类来处理 Web 请求。 实现这一目标的最佳方法是什么? 我的想法是创建一个JavaApplication的.jar文件,其中包含所有.class文件、 /resources和/libs 。 通过这种方式,我可以将 .jar 包含在 Web 应用程序中,并且我可以拥有一个包含整个应用程序的.war文件。 你怎么认为? 这个问题通常是如何解决的? 注意:我不想将 Java 项目转换为 Web 项目。 回答1 在 Eclipse 项目属性中,将项目添加到Java EE 模块依赖项(Eclipse 3.5 或更早版本) 或项目属性中的部署程序集(Eclipse 3.6 或更高版本)条目。 这样 Eclipse 将负责做正确的事情来创建一个 WAR(它将以
  • 开发Android应用程序的最佳IDE是什么? [关闭](What is the best IDE to develop Android apps in? [closed])
    问题 从目前的情况来看,这个问题不适合我们的问答形式。 我们希望答案会得到事实,参考或专业知识的支持,但是这个问题可能会引起辩论,争论,民意测验或进一步的讨论。 如果您认为此问题可以解决并且可以重新提出,请访问帮助中心以获取指导。 8年前关闭。 我即将开始开发android应用,并且需要获取IDE。 Eclipse和android eclipse插件似乎是自然的选择。 但是,我对intelliJ和re-shaper很熟悉,所以我更喜欢使用intelliJ。 有人使用过https://code.google.com/archive/p/idea-android/吗? 这有什么好处吗? 我应该只是硬着头皮学习Eclipse吗? 回答1 最新消息 Android Studio已正式发布Beta版并已发布。 现在,它已成为Android开发的官方IDE-不再支持Eclipse。 它绝对是Android开发的首选IDE。 链接到下载页面:http://developer.android.com/sdk/index.html 消息 从Google I / O 2013开始,Android团队已使用新的Android Studio IDE转移到IntelliJ Idea:http://developer.android.com/sdk/installing/studio.html
  • 如何从另一个 eclipse 插件项目调用 jar 中的方法?(How can I call a method in jar from another eclipse plugin project?)
    问题 我想从另一个依赖于该项目的 eclipse 插件项目调用 jar 中的方法。 但是eclipse无法解析jar中的类名。 例子: 我创建了com.plugin.main和com.plugin.sub项目。 将 poi-ooxml-xxx.jar 添加到com.plugin.sub项目并通过首选项对话框添加构建路径。 将 jar 中的所有包作为导出包添加到com.plugin.sub project MANIFEST.MF。 将com.plugin.sub作为必需插件添加到 com.plugin.main 项目中的 MANIFEST.MF。 但是 Eclipse 无法从 com.plugin.main.actions.SampleAction 解析 jar WorkbookFactory的类名。 为什么? 信息: 日食 3.6(太阳神) JavaSE-1.7。 WorkbookFactory的 FQCN 是org.apache.poi.ss.user.model.WorkbookFactory 。 com.plugin.main MANIFEST.MF : Manifest-Version: 1.0 Bundle-ManifestVersion: 2 Bundle-Name: Main Bundle-SymbolicName: com.plugin.main
  • 如何排除在Eclipse项目中产生警告/错误的文件夹?(How to exclude a folder that is producing warnings/errors in an Eclipse project?)
    问题 好的。 我已经厌倦了这个问题。 这必须有一个简单的解决方法,我敢肯定! 我希望SO可以帮助我一劳永逸地摆脱这一困境! 问题我们如何使Eclipse停止尝试处理/编译特定项目目录下的所有文件? 目的是在问题视图中不存在与该文件夹或其子文件夹中的某些内容相关的错误/警告。 背景 我们运行Eclipse 3.6,而m2eclipse插件v0.10.2.20100623管理我们的自动构建。 由于我无法控制的原因,我们在SVN项目目录中的src/main/resources/blazeds下拥有完整的BlazeDS发行版。 本质上,此目录包含运行中的tomcat的原始分布,当我们通过SCP部署到服务器时,我们的所有配置和项目文件都添加到了其中。 因此,当我们运行deploy时,此版本的tomcat被复制到服务器,并且我们的项目被放置在其中。 Tomcat和我们的RIA应用程序正常工作,一切都很好。 问题是,Eclipse在运行AutoBuild时会尝试在src/main/resources/blazeds下编译所有内容,这会在我们的问题视图中生成大约300个错误/警告。 因此,当实际错误浮出水面时,它就会在噪声中丢失。 错误源自/blazeds/tomcat/webapps/samples/testdrive-datapush traderdesktop代码,以及testdrive
  • 适用于 Ubuntu 10.10 的 Eclipse 3.6 Helios [关闭](Eclipse 3.6 Helios for Ubuntu 10.10 [closed])
    问题 关闭。 这个问题需要更加集中。 它目前不接受答案。 想改善这个问题吗? 更新问题,使其仅通过编辑这篇文章来关注一个问题。 5年前关闭。 改进这个问题 我的戴尔工作室笔记本电脑上安装了 ubuntu 10.10 上网本版本。 我为 eclipse 站点下载了 helios,但是当我无法运行它时。 我已经从突触包管理器下载了 eclipse 3.5,但我无法将 eclipse 3.5 更新到 eclipse 3.6。 有没有其他方式来更新日食? Eclipse 3.6 支持 HTML 5。 请让我知道,非常感谢提前 回答1 试试这个: 要在 ubuntu 上安装 eclipse,您需要先从 http://www.eclipse.org/downloads/ 下载它,右键单击下载的文件并在此处解压缩或运行以下命令: tar xzf dir/eclipse-SDK-3.3.1.1-linux-gtk.tar.gz 其中 eclipse-SDK-3.3.1.1-linux-gtk 是您的 eclipse-SDK 名称和版本,而 dir 是 eclipse-sdk 的目录。 现在将其移动到根目录。 应用以下命令来执行此操作。 sudo mv dir/eclipse ~ 现在您已准备好配置您的 eclipse。 要做到这一点,请按照以下步骤一步一步... sudo mv eclipse
  • 如何将番石榴添加到 Eclipse 项目中(How to add Guava to Eclipse project)
    问题 日食太阳神 3.6 视窗 XP SP3 我已经使用 Eclipse 通过执行以下操作来下载番石榴 SDK: 1) 在 Eclipse 中,转到帮助 > 安装新软件... 2) 在“ Work with: ”文本框中,我使用了以下 URL http://svn.codespot.com/a/eclipselabs.org/guava-bundle/trunk/repository/ 3) 它找到了 Guava: Google Core Libraries for Java 1.5 Runtime 和 SDK,所以我对每条消息都点击了“确定”,它们似乎安装得很好。 现在我想在我的代码中使用它(对于 Android 应用程序)我正在尝试将导入添加到我的一个类文件中 import com.google.common.collect.MapMaker; 我收到一条编译错误消息 导入 com.google 无法解析 是否需要执行任何特殊步骤才能将库添加到我的项目中? 我一直在查看项目属性,我有一种感觉,我需要向Java Build Path > Libraries添加一个条目,但我不知道要添加什么。 回答1 据我所知,Google Guava 不是 Eclipse 插件。 这是第三方库。 要将 lib 添加到 Eclipse 构建路径,只需右键单击您的项目 -> 构建路径 ->
  • Eclipse 在启动时冻结 - 在加载工作区之前(Eclipse freezing at startup - before loading workspace)
    问题 早上的第一件事,就在我打开我的 PC (Windows XP) 并启动我的 Eclipse 之后,它只是显示启动画面,然后冻结。 大约 20 分钟后,它会询问我要加载哪个工作区。 问题发生在 3.5 和 3.6 Eclipse 上。 在 3.6 Eclipse 安装中,我只有标准的 PDE 安装 + Google 插件(用于 GWT 开发)+ Subclipse。 因为我已将其配置为向我询问工作区,所以我可以看到它与工作区或项目无关。 我怀疑是谷歌插件,因为在安装之前我没有遇到任何问题,但我已经搜索过并且没有遇到任何报告类似问题的人。 它只执行一次 - 在我早上打开机器后立即执行。 在此之后它开始正常 - 通常在几秒钟内。 它可能在做什么? 我怎样才能知道它在做什么? 回答1 @CharlesB 发布的链接使我朝着正确的方向前进,但我发现您只需要删除位于此处的.snap文件: [Workspace Directory]/.metadata/.plugins/org.eclipse.core.resources/.snap (注意.metadata目录是隐藏的。) 回答2 也许这篇博文可以帮助: 在您的工作区目录中执行以下步骤: cd .metadata/.plugins mv org.eclipse.core.resources org.eclipse.core
  • Eclipse GDB MacOSX Mavericks [closed]
    Closed. This question needs details or clarity. It is not currently accepting answers. Want to improve this question? Add details and clarify the problem by editing this post. Closed 7 years ago. Improve this question I have had terrible problems making an Application Debug using Eclipse C/C++ project with XCode 5.0 and I have finally made it. I have finally been able to successfully debug my application and that's why I decided to make this little tutorial hoping to save time to others. When trying to debug and application written in C/C++ on Eclipse on Mavericks OS it comes up with "Error
  • Eclipse GDB MacOSX小牛(Eclipse GDB MacOSX Mavericks [closed])
    问题 关门了。 这个问题需要细节或明确性。 它当前不接受答案。 想要改善这个问题吗? 添加详细信息,并通过编辑此帖子来澄清问题。 7年前关闭。 改善这个问题 我在使用带有XCode 5.0的Eclipse C / C ++项目进行应用程序调试时遇到了严重的问题,我终于做到了。 我终于能够成功调试我的应用程序,这就是为什么我决定制作此小教程,以希望节省其他人的时间的原因。 当尝试在Mavericks OS上的Eclipse上调试和使用C / C ++编写的应用程序时,会出现“错误gdb-版本”。 这是因为Eclipse在新的Mac OSX上找不到GDB调试,因为Apple停止了对GDB的支持,而不是LLDB。 要检查您是否遇到这种情况,只需尝试从Terminal gdb运行,它将显示为找不到文件。 问题在于尚未为Eclipse配置LLDB(或者相反)。 那么,如何像以前的10.8 OS中一样,使Eclipse重新调试应用程序? 首先获取并编译GDB。 您有两种可能的选择: Macports(不幸的是,Mavericks发行版被卡在Building getext库中) 自制酒 我的建议是从Homebrew获得它。 在他们的网站上查看下载链接并使用 ruby -e "$(curl -fsSL https://raw.github.com/mxcl/hebrew/go)" 让它安装。
  • 如何将 Eclipse RCP 3.6 项目升级到 4(How to upgrade Eclipse RCP 3.6 project to 4)
    问题 我想升级我昨天上线的 Eclipse RCP 项目,它是使用 Eclipse RCP 3.6 版本开发的(代码就像紧耦合,因为我没有使用 Spring DI),作为未来的路线图考虑,我想升级我的项目到 Eclipse 4。升级的主要原因是在我的 RCP 应用程序中使用 spring DI 和 CSS。 我可以在我的 Eclipse RCP 3.6 项目中进行 spring 集成和 CSS,还是应该从创建 RCP 4 Scratch 项目开始。 头脑风暴的想法,实际上。 任何方向和建议都会很棒。 回答1 要回答您的第一个问题……当然可以在 Eclipse 3.6 中使用 Spring DI,但是 Eclipse RCP UI 的当前 CSS 样式直到 Eclipse 4 才引入。 我无法解决您是否应该或不应该创建 RCP 4 Scratch 项目的问题。 这是一个艰难的决定,应该由对您的项目及其未来目标有深入了解的人做出。 至于方向和建议……我有两个信息来源供您参考。 拉斯·沃盖拉。 他的教程站点组合得非常好,我认为对于任何想要学习 Eclipse RCP 开发基础知识的人来说,它们都是必不可少的。 不幸的是,这些教程可能不够详细,无法为您提供帮助。 这取决于您当前的 Eclipse RCP 知识水平。 http://www.vogella.com/tutorials.html
  • 如何在 Eclipse 中使用 GDB 进行 C/C++ 调试?(How do I use GDB in Eclipse for C/C++ Debugging?)
    问题 我是 Visual Studio 用户,习惯于使用断点进行调试。 我现在在 linux 环境中工作,并使用 Eclipse 作为 IDE。 我是 linux 和 eclipse 的新手。 我不知道如何在 Eclipse 中使用 gdb。 我尝试在命令行中使用 gdb,但并不像拥有 UI 那样容易。 我如何在 Eclipse 中使用 gdb? 回答1 以下说明适用于 Eclipse 3.5 (Galileo)。 对于 3.6 (Helios),除了步骤 2 中的链接外,它们是相似的。 转至帮助 > 安装新软件。 将 CDT 存储库 http://download.eclipse.org/tools/cdt/releases/galileo 添加到存储库列表。 选择 CDT 存储库。 现在您需要从可用插件列表中安装 CDT 插件以及 GDB 支持(选择 CDT 主要功能以及 CDT GNU 工具链调试支持)。 您现在应该能够在 Eclipse 中设置断点并检查变量的值。 另一种方法是安装 DDD(GDB 的 GUI 前端)。 回答2 首先下载 Eclipse CDT 确保您可以将项目导入 Eclipse,如下所示:如何从 Eclipse 中的现有源创建项目然后找到它? 您可以尝试使用这个简单的测试目录进行测试:https://github.com/cirosantilli/ide
  • Eclipse Europa、Helios、Galileo 之间的区别(Difference between Eclipse Europa, Helios, Galileo)
    问题 Eclipse 版本(Europa、Helios、Galileo)之间有什么区别? 哪个最适合桌面应用程序? 回答1 维基百科上的 Eclipse(软件)页面对其进行了很好的总结: 发布自 2006 年以来,Eclipse 基金会每年都会协调一次同步发布。 每个版本都包含 Eclipse 平台以及许多其他 Eclipse 项目。 在伽利略发布之前,发布的版本都是以太阳系的卫星命名的。 到目前为止,每个同步发布都发生在 6 月底。 发布 主发布 平台版本 项目 光子 2018 年 6 月 27 日 4.8 氧气 2017 年 6 月 28 日 4.7 霓虹灯 2016 年 6 月 22 日 4.6 火星 2015 年 6 月 24 日 4.5 火星项目 Luna 2014 年 6 月 25 日 4.4 Luna 项目 开普勒 2013 年 6 月 26 日 4.3 开普勒项目 朱诺 2012 年 6 月 27 日 4.2 朱诺项目 Indigo 2011 年 6 月 22 日 3.7 Indigo 项目 Helios 2010 年 6 月 23 日 3.6 Helios 项目 伽利略 2009 年 6 月 24 日 3.5 伽利略项目 木卫三 2008 年 6 月 25 日 3.4 木卫三项目 欧罗巴 2007 年 6 月 29 日 3.3 欧罗巴项目 Callisto
  • 如何让 Eclipse Debug Server 调试 rails 应用程序?(How do I get Eclipse Debug Server to debug rails application?)
    问题 我有一个简单的 rails 应用程序,当我使用命令行“rails server”启动时,它会在 Eclipse Juno 中运行。 我现在需要在 eclipse ide 中进行调试并设置断点,但我无法弄清楚如何使用“运行服务器”、“调试服务器”、“运行方式”或“调试方式”在 Eclipse 中运行服务器。 什么都没有发生,没有输出到控制台,什么都没有。 我的 gemlist 有:使用 debugger-linecache (1.2.0)/ Using debugger-ruby_core_source (1.3.2)/ Using debugger (1.6.6) 我成功运行了 bundle install 和 'gem install debugger'。 我有 Ruby 1.93,Rails 3.2.17 Windows 7。重新启动。 我在我的 MAC 上配置了一个带有调试器的 eclipse 环境,但是我找不到 Windows 设置的缺失部分。 非常感谢, 安妮 回答1 我的 eclipse + aptana 插件也有类似的问题。 当我选择“调试/运行服务器”时,什么也没发生。 问题出在项目结构上。 就我而言,我在 eclipse 中有一个空的 rails 项目 (testProject),并从文件系统 (railsApp) 导入了我的 rails 应用程序。 因此
  • 如何将现有的 eclipse java 项目添加到 git(How do I add existing eclipse java project to git)
    问题 如何将eclipse中现有的java项目添加到git? 我注意到在创建项目时有一个选项可以添加到源代码管理,但我找不到现有项目的这个选项。 这可以从 eclipse 中的 git 插件中实现还是必须从命令行完成? (我使用的是 Mac) 回答1 另一种方法(我发现内置的 Eclipse 工具有时很挑剔): 打开你的终端导航到您的项目目录输入git init创建一个仓库假设该文件夹中已有文件,输入git add --all将所有文件添加到存储库(注意:如果跳过此步骤,您将拥有一个空存储库。您也可以使用git add filename仅添加特定的git add filename文件/文件夹) 输入git commit -m "your message here"来执行你的第一次提交 此时,您有一个全新的本地存储库,其中包含您的文件! 以下步骤将其连接到远程存储库。 创建您的远程存储库(以 GitHub 为例,只需单击“ New按钮,然后按照提示进行操作。 打开你的终端并导航到你的项目目录在您的存储库页面上,您应该会看到一个以your-repository-name.git结尾的 HTTPS 链接将git remote add origin粘贴到您的终端中,然后是该 HTTPS 链接将git push -u origin master粘贴到您的终端中(注意:最后两个步骤也显示在