天道酬勤,学无止境

Not getting info message after converting rvm from .rvmrc to .ruby-version

I've just run rvm rvmrc to ruby-version on a couple of projects. Looked at the produced files, they match what googling says should be in them (.ruby-version & .ruby-gemset).

When I cd into the project directories, I no longer get the Using /home/user/.rvm/gems/ruby-1.9.3-p392 with gemset projectname info message.

Is there any way for get info message back?

Thanks.

标签

评论

it should be enough to run:

echo rvm_use_flag=2 >> ~/.rvmrc

It will tell RVM to display the message always (it does not work for some older project .rvmrc files that did not support it).

受限制的 HTML

  • 允许的HTML标签:<a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type> <li> <dl> <dt> <dd> <h2 id> <h3 id> <h4 id> <h5 id> <h6 id>
  • 自动断行和分段。
  • 网页和电子邮件地址自动转换为链接。

相关推荐
  • 使用rvmrc或ruby-version文件通过RVM设置项目gemset?(Use rvmrc or ruby-version file to set a project gemset with RVM?)
    问题 我使用RVM,Ruby版本管理器为我的每个Rails项目指定一个Ruby版本和一组gem。 我有一个.rvmrc文件,可以在每次cd进入项目目录时自动选择Ruby版本和gemset。 安装RVM 1.19.0后,我收到一条消息 您正在使用.rvmrc ,它需要信任,速度较慢,并且与其他ruby管理器不兼容,您可以使用rvm rvmrc to [.]ruby-version切换到.ruby-version rvm rvmrc to [.]ruby-version或rvm rvmrc to [.]ruby-version或通过rvm rvmrc warning ignore /Users/userName/code/railsapps/rails-prelaunch-signup/.rvmrc忽略此警告rvm rvmrc warning ignore /Users/userName/code/railsapps/rails-prelaunch-signup/.rvmrc , .rvmrc仍将是默认的项目文件中RVM 1和2 RVM,对所有文件运行忽略警告rvm rvmrc warning ignore all.rvmrcs 。 我应该继续使用.rvmrc文件还是应该切换到.ruby-version文件? 哪个是最佳的? 有哪些后果? 回答1 如果您的
  • Use rvmrc or ruby-version file to set a project gemset with RVM?
    I use RVM, the Ruby Version Manager to specify a Ruby version and a set of gems for each of my Rails projects. I have a .rvmrc file to automatically select a Ruby version and gemset whenever I cd into a project directory. After installing RVM 1.19.0, I get a message You are using .rvmrc, it requires trusting, it is slower and it is not compatible with other ruby managers, you can switch to .ruby-version using rvm rvmrc to [.]ruby-version or ignore this warnings with rvm rvmrc warning ignore /Users/userName/code/railsapps/rails-prelaunch-signup/.rvmrc, .rvmrc will continue to be the default
  • Ruby on Rails Mac OSX Mavericks issues after RVM install
    I have been learning Ruby on Rails for a couple of months, and everything was working. Then, for the needs of a tutorial, I tried to install RVM, in order to downgrade my setup to older versions of Ruby and Rails. And since then, I kept running into troubles. For instance, anytime I launch a new Terminal session, here is what I get: You are using '.rvmrc', it requires trusting, it is slower and it is not compatible with other ruby managers, you can switch to '.ruby-version' using 'rvm rvmrc to [.]ruby-version' or ignore this warning with 'rvm rvmrc warning ignore /Users/Thibaud/work/.rvmrc', '
  • pow 说:Bundler::GemNotFound:在任何来源中都找不到 rake-0.9.2.2(pow says: Bundler::GemNotFound: Could not find rake-0.9.2.2 in any of the sources)
    问题 我有一个轨道运行与精细的应用程序rails s ,但是当我尝试使用POW我得到这个错误加载它: Bundler::GemNotFound: Could not find rake-0.9.2.2 in any of the sources ~/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.22/lib/bundler/spec_set.rb:88:in `block in materialize' ~/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.22/lib/bundler/spec_set.rb:82:in `map!' ~/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.22/lib/bundler/spec_set.rb:82:in `materialize' .... 奇怪的是,此应用程序中的.rvmrc文件指定1.9.3-p125 : which rake .../.rvm/gems/ruby-1.9.3-p125/bin/rake 这是我运行bundle install时看到的内容: Using rake (0.9.2.2) FWIW,pow与使用1.9.2和其他gemset的另一个非Rails项目很好地配合。 谢谢! 回答1 我猜你更新了
  • 我应该输入`.ruby-gemset`和/或`.ruby-version`吗?(Should I check in `.ruby-gemset` and/or `.ruby-version`?)
    问题 我刚刚更新了RVM,并代替了旧的.rvmrc ,它自动创建了.ruby-gemset和.ruby-version 。 我一直都有.rvmrc文件,其内容类似于rvm use --create default@project_name 。 但是, .ruby-version包含我正在运行的特定Ruby版本,而不是default 。 我很乐意签入。 另外,我在播客上听到有人说,不应该签入.ruby-gemset因为其他人可能对如何命名.ruby-gemset有自己的偏好。 我什么时候应该或不应该签入.ruby-gemset和/或.ruby-version ? 具体来说: 权衡有哪些? 项目类型如何影响决策(例如,应用程序vs宝石)? 如果应将其检入,项目类型如何影响这些文件中应包含的内容? 来自rvm,rbenv等工具的创建者的引用将得到解答。 回答1 对于标准项目 如果您的项目依赖于ruby-2.0.0类的ruby-2.0.0请.ruby-version入.ruby-version 。 仅在您的团队同意后才能.ruby-gemset入.ruby-gemset 。 将.rvmrc添加到.gitignore以便任何人都可以使用.rvmrc覆盖.ruby-*文件设置。 对于宝石 仅当您的项目仍以ruby 1.8.7目标时,才使用ruby-1.8.7检入.ruby-version
  • 使用 rvm 创建 .ruby-version 和 .ruby-gemset(Create .ruby-version and .ruby-gemset with rvm)
    问题 在创建新的 gemset 时,有没有办法创建关联的.ruby-version和.ruby-gemset文件? 对于旧版本的 rvm,可以执行rvm --create --rvmrc 1.8.7@project ,但这会创建.rvmrc文件。 我以为我在某个地方读到了我们可以使用--ruby-version命令行开关的地方,但是我这样做没有成功。 回答1 我最近遇到了同样的问题。 rvm --help引导我: rvm --create --ruby-version ruby-1.9.3@my-gemset 它创建了.ruby-gemset和.ruby-version 。 回答2 根据官方 RVM 文档,您可以使用: echo 1.9.3 > .ruby-version 或者你可以使用这个: rvm --ruby-version use 1.9.3@my_app 第二种形式将创建.ruby-version和.ruby-gemset 。 回答3 假设我正在为名为tptapp 的rails 应用程序创建 gemset,那么我们可以通过以下方式进行操作。 rvm use 2.2.2@tptapp --create 这里tptapp是 gemset 的名称,2.2.2 是 Ruby 版本。 回答4 以上所有示例都要求您输入您的 ruby​​ 版本和 gemset 名称 .. 这与 vi
  • 如何使用 RVM 管理多个 gemset 和 ruby​​ 版本?(How to manage multiple gemsets and ruby versions with RVM?)
    问题 我真的对 RVM 网站上给出的解释感到困惑。 我不清楚不同 ruby​​ 解释器和 gemset 之间的关系。 在我看来,是这样的—— 我的 Mac 帐户有一个 rvm 该 rvm 安装和管理一组不同版本的 ruby​​ 解释器。 每个 ruby​​ 版本都有一套 gemsets。 我把事情说清楚了吗……欢迎更多的解释。 我可以从事(Ruby 1.8.7 + rails 2.3.8 及其依赖项)和(Ruby 1.9.2 和 Rails 3.0 及其依赖项)... 如果有人精通在 rvm 的帮助下处理许多 ruby​​ 版本和 gemsets,请向我解释......感谢您的帮助 回答1 这是我喜欢这样做的方式... 使用 RVM 安装 ruby 切换到/使用那个红宝石为项目创建 gemset 切换到/使用该 gemset 安装所需的宝石创建一个指向我选择的 ruby​​ 和 gemset 的别名切换到/使用该新别名(同样,与项目相关联) 对于您希望彼此分开的不同项目,请根据需要多次执行此操作。 例子: $ rvm install ruby-1.9.2 ... $ rvm list rvm rubies => ree-1.8.7-head [ i386 ] ruby-1.9.2-head [ i386 ] ruby-1.9.2-preview3 [ i386 ] $ rvm
  • Create .ruby-version and .ruby-gemset with rvm
    Is there a way to create the associated .ruby-version and .ruby-gemset files when creating a new gemset? With older versions of rvm, one could do rvm --create --rvmrc 1.8.7@project, but that creates .rvmrc files. I thought I read somewhere we could use the --ruby-version command line switch, but I have been unsuccessful in doing so.
  • Should I check in `.ruby-gemset` and/or `.ruby-version`?
    I've just updated RVM, and in place of the old .rvmrc, it auto-created .ruby-gemset and .ruby-version. I've always had .rvmrc files with contents like rvm use --create default@project_name. However, .ruby-version contains the specific Ruby version I'm running rather than default. I'm hesitant to check this in. Also, I heard someone say on a podcast that one shouldn't check in .ruby-gemset because others may have their own preferences about how to name gemsets. When should or shouldn't I check in .ruby-gemset and/or .ruby-version? Specifically: What are some of the tradeoffs? How does the type
  • 尝试使用capistrano进行部署时,为什么会出现Psych错误?(Why am I getting a Psych error when trying to deploy with capistrano?)
    问题 我目前正在我的Rails 3.2.13应用程序中设置capistrano。 我收到以下错误/详细信息(包括“第1行第1列不允许使用控制字符”)。 我已经为此进行了一些搜索,但是没有看到任何与我相关的信息。 我正在使用rvm-capistrano和ruby 2.0.0-p195。 最近,我将应用程序所需的环境变量移到了.bashrc中。 ... * 2013-06-10 15:18:32 executing `deploy:assets:update_asset_mtimes' * executing "[ -e /home/deployer/apps/super_rad_app/shared/assets/manifest* ] && cat /home/deployer/apps/super_rad_app/shared/assets/manifest* || echo" servers: ["107.20.249.163"] [107.20.249.163] executing command command finished in 6238ms *** [deploy:update_code] rolling back * executing "rm -rf /home/deployer/apps/super_rad_app/releases
  • 为什么我在任何来源中都找不到 multi_json-1.3.1?(Why I am getting Could not find multi_json-1.3.1 in any of the sources?)
    问题 我有一个简单的 Rails 应用程序,我想部署到 Heroku。 当我运行以下命令时 git push heroku master 显示以下错误消息。 Could not find multi_json-1.3.1 in any of the sources ! ! Failed to install gems via Bundler. ! ! Heroku push rejected, failed to compile Ruby/rails app 这是我的 Gemfile gem 'rails', '3.2.3' gem 'pg' group :assets do gem 'sass-rails', '~> 3.2.3' gem 'coffee-rails', '~> 3.2.1' gem 'therubyracer', :platform => :ruby gem 'uglifier', '>= 1.0.3' end gem 'jquery-rails' 回答1 删除 Gemfile.lock 文件,然后运行 ​​bundle install。 这对我有用! 回答2 尽管我知道这些 gems 可用,但我还是看到了针对不同 gem 的一系列这些错误(例如gem list -r <gem>显示它们,包括版本;浏览 ruby​​gems.org
  • “你的 Ruby 版本是 1.9.3,但你的 Gemfile 指定了 1.9.3-p194”(“Your Ruby version is 1.9.3, but your Gemfile specified 1.9.3-p194”)
    问题 RVM 不会让我运行bundle因为它认为我的 Ruby 版本与我的 Gemfile 所说的不同,但事实并非如此: $ rvm list rvm rubies => ruby-1.9.3-p194 [ x86_64 ] ruby-1.9.3-p429 [ x86_64 ] * ruby-2.0.0-p195 [ x86_64 ] # => - current # =* - current && default # * - default $ ruby -v ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin13.0.0] 宝石档案: ruby '1.9.3-p194' 但是之后: $ bundle install Your Ruby version is 1.9.3, but your Gemfile specified 1.9.3-p194 $ 这似乎是一件非常奇怪的事情。 有任何想法吗? 有这个疑问的人很多,但是他们的Gemfiles和运行的版本明显不同。 我什至完成了rvm use 1.9.3-p194 ,然后在bundle install之后立即完成,但我得到了同样的错误。 bundle update产生相同的错误。 如果我从 Gemfile 中删除 ruby​​ 版本,它将默认为 2.0.0
  • Bundler :: RubyVersionMismatch:您的Ruby版本是1.9.3,但是您的Gemfile指定了2.0.0(Bundler::RubyVersionMismatch: Your Ruby version is 1.9.3, but your Gemfile specified 2.0.0)
    问题 我将Mac与Pow,Ruby,Rails和许多有用的宝石一起使用。 每当我尝试打开我的应用程序时,我都会收到此错误。 Bundler :: RubyVersionMismatch:您的Ruby版本是1.9.3,但是您的Gemfile指定了2.0.0 我理解该错误,但是在这里找不到为什么它没有使用正确的版本。 一些有用的信息: 堆栈跟踪 Bundler::RubyVersionMismatch: Your Ruby version is 1.9.3, but your Gemfile specified 2.0.0 ~/.rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/definition.rb:361:in `validate_ruby!' ~/.rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler.rb:116:in `setup' ~/.rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/setup.rb:17:in `<top (required)>' ~/Dropbox/Documents/project/Sites/project-profile/config.ru:3:in
  • Unknown ruby interpreter version (do not know how to handle): RUBY_VERSION
    Trying to rvm use . in order to follow the instructions in here in an attempt to fix my messed up configuration, I get the following message in console: Unknown ruby interpreter version (do not know how to handle): RUBY_VERSION. Could not determine which Ruby to use; . should contain .rvmrc or .versions.conf or .ruby-version or .rbfu-version or .rbenv-version, or an appropriate line in Gemfile. Which I guess refers to the variable RUBY_VERSION in the Gemfile: source "https://rubygems.org" ruby RUBY_VERSION What should I do? I guess RUBY_VERSION variable has to be defined as a system variable
  • 在 Mac 10.7 上运行“requirements_osx_brew_libs_install...”时出错(Error running 'requirements_osx_brew_libs_install…' on Mac 10.7)
    问题 尝试在上一代 Macbook Pro 上安装 brew 并不断收到以下错误: 运行“requirements_osx_brew_libs_install autoconf automake libtool pkg-config apple-gcc42 libyaml readline libxml2 libxslt libksba openssl sqlite”时出错, 请阅读/Users/allegrascrugham/.rvm/log/ruby-1.9.3-p392/1368142352_package_install_autoconf_automake_libtool_pkg-config_apple-gcc42_libyaml_readline_libxml2_libxslt_libksba_openssl_sqlite。 我尝试删除并重新安装 RVM & Brew,但没有成功。 回答1 运行rvm requirements时我遇到了完全相同的错误。 除了安装包失败之外,该日志文件没有给出任何提示。 这对我有用: 在它失败之前从最后一个包开始,在你的情况下sqlite 。 然后像这样手动安装: brew install sqlite 然后再次运行rvm requirements ,它可能会在较早的包中失败。 重复以上步骤。 回答2 您必须手动安装这些依赖项,请尝试
  • RVM keeps adding a directory to my PATH and then throws a warning that PATH isn't set up correctly
    I know there's a lot of other questions out there addressing this issue, but I haven't been able to find anything solution that works for me, so I'm posting in case I've missed something. Using the command-line, when I cd into a Rails site directory, RVM changes my path by adding "Users/username/bin" to the front of the PATH variable and then it throws a warning about how PATH is not set up correctly because because the ruby gems version isn't in first place in PATH. Here's my $PATH output prior to changing into a ROR directory: /Users/username/.rvm/gems/ruby-2.1.1/bin:/Users/username/.rvm
  • RVM 报告 Gemfile ruby​​ 未安装(RVM reports Gemfile ruby as not installed)
    问题 在我的 Gemfile 中,我指定了: ruby '1.9.3', engine: 'jruby', engine_version: '1.7.9' 但是进入我的 Rails 项目目录会使rvm抛出这个错误: RVM used your Gemfile for selecting Ruby, it is all fine - Heroku does that too, you can ignore these warnings with 'rvm rvmrc warning ignore /home/petey/rails/kotoba/Gemfile'. To ignore the warning for all files run 'rvm rvmrc warning ignore allGemfiles'. ruby-1.9.3,engine:jruby,engine_version:1.7.9 is not installed. To install do: 'rvm install ruby-1.9.3,engine:jruby,engine_version:1.7.9' 但是,我确实安装了 jruby 1.7.9: $ rvm list rvm rubies jruby-1.7.9 [ x86_64 ] ruby-1.9.3-p392 [ x86_64 ] =*
  • find_spec_for_exe':找不到宝石捆绑包(> = 0.a)(Gem :: GemNotFoundException)(find_spec_for_exe': can't find gem bundler (>= 0.a) (Gem::GemNotFoundException))
    问题 我使用sudo bundle install ,那可能是问题的原因吗? 我现在有: gem -v 2.6.14 ruby -v ruby 2.3.5p376(2017-09-14修订版59905)[x86_64-darwin15] jekyll -v jekyll 3.6.2 bundle -v Bundler版本1.16.0.pre.3 尝试运行bundle exec jekyll serve或仅jekyll serve时出现以下错误 /Users/myusername/.rvm/rubies/ruby-2.3.5/lib/ruby/site_ruby/2.3.0/rubygems.rb:271:in `find_spec_for_exe': can't find gem bundler (>= 0.a) (Gem::GemNotFoundException) from /Users/myusername/.rvm/rubies/ruby-2.3.5/lib/ruby/site_ruby/2.3.0/rubygems.rb:299:in `activate_bin_path' from /Users/myusername/.rvm/gems/ruby-2.3.5/bin/bundle:23:in `<main>' from /Users/myusername/.rvm
  • Upgraded to Ruby version 2.1.2, passenger still on 1.9.3
    How do I update the Ruby Version used by Passenger whenever I update Ruby and its Gemlist using RVM and Capistrano? What is the best way to check if my app is using the right ruby version and gemset? I have a Rails app running on a Linode server (Ubuntu), with NGinx and Passenger. Before it was running without any problem. Previously my app was running Ruby on Rails 3.2.16 with the Ruby 1.9.3-p194 I use RVM to manage ruby versions both locally and on the server. After I installed Ruby-2.1.2 and updated the basic gems (bundler, nokogiri, etc...) I created my new gemset for my application. In
  • 如何从Ubuntu删除Ruby(How to remove Ruby from Ubuntu)
    问题 我要删除Ruby,因此尝试此操作。 我该如何删除? sudo apt-get autoremove ruby Reading package lists... Done Building dependency tree Reading state information... Done Package 'ruby' is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 534 not upgraded. here@jaskaran:/$ whereis ruby ruby: /usr/bin/ruby /usr/lib/ruby /usr/bin/X11/ruby /usr/share/man/man1/ruby.1.gz here@jaskaran:/$ ruby -v ruby 1.9.3p194 (2012-04-20 revision 35410) [i686-linux] 回答1 Ubuntu ...? 使用它来找出您正在运行的可执行文件: $ which ruby /usr/bin/ruby 使用它来找出实际上是什么: $ readlink -f /usr/bin/ruby /usr/bin/ruby1.8 使用它来找出它属于哪个包: $ dpkg -S